lp:ubuntu/maverick/texlive-bin

Created by James Westby on 2010-04-30 and last modified on 2010-08-14
Get this branch:
bzr branch lp:ubuntu/maverick/texlive-bin
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

18. By Norbert Preining on 2010-08-10

* add ed (and perl, texlive-common) to the list of dependencies (LP: #577305)
  (Closes: #580732)
* remove texconfig warning/exit (with tlmgr link) statement and rely
  on fmtutil being debianized (Closes: #588731)

17. By Anders Kaseorg on 2010-08-14

Add missing dependency on ed to texlive-binaries. (Closes: #580732,
LP: #577305)

16. By Didier Roche on 2010-08-05

No-change upload to build against current poppler library ABI.

15. By Norbert Preining on 2010-05-01

[ Frank Küster ]
* include a patch that allows texconfig to handle more default paper
  settings. This is intended to be submitted upstream, and to be used
  to address #402994 (libpaper integration) [fk]

[ Norbert Preining ]
* include (lost) man pages for texconfig-dialog, devnag, bibtex8,
  omfonts, otangle, pdfopen (no bug, but see #574796)
* add a patch upstream-web2c-tmpfilewithpid that fixes overwriting
  files with -recorder in parallel builds (Closes: #575731).
* bump standards version to 3.8.4, no changes necessary
* bump build-dep on libpoppler to 0.12.4 (against my will!!)
  (Closes: #577684)
* Fix CVE-2010-1440: this overrides the incomplete fix for CVE-2010-0793.

[ Security Team ]
Fixed in 2009-5+nmu1
* Fix CVE-2010-0827: buffer overflow in dvips (virtualfont.c).

14. By Norbert Preining on 2009-12-26

* include a patch (from upstream) to fmtutil so that multiple
  defined formats are accepted. That is the definitive fix for bug
  #557091, but the other one is necessary, too.
* install synctex.5 man page
* manage bibtex with alternatives, code by Андрей Парамонов

13. By Norbert Preining on 2009-10-22

* Include patches from Ubuntu for libpoppler 0.0.12 support
  (Closes: #548878) (LP: #383825)
* Add another patch fix-getline-libc10-horror that fixes another
  unreported FTBFS because libc now exports getline

12. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-09-28

* Merge from Debian unstable, remaining changes: (LP: #438092)
  + debian/patches/ubuntu_libpoppler-0.11: fix a FTBFS because of unuseful
    call to GfxFont destructor (virtual and protected) (LP: #383825)
  + debian/patches/65_fix_getline_glibc2.10.patch: fix FTBFS by renaming
    included getline-functions to not conflict with glibc provided getline.
  + debian/fix-manpages.sh: quote special chars in sed command
* debian/patches/ubuntu_libpoppler-0.12: fix a FTBFS with libpoppler 0.12:
  use getPDFMinorVersion instead of getPDFVersion. (LP: #438031)

11. By Andreas Moog on 2009-08-10

* rebuild for new libpoppler, fixes various crashes (LP: #410242)
* debian/patches/65_fix_getline_glibc2.10.patch: fix FTBFS by renaming
  included getline-functions to not conflict with glibc provided getline.
* debian/fix-manpages.sh: quote special chars in sed command

10. By Fabrice Coutadeur on 2009-06-05

debian/patches/ubuntu_libpoppler-0.11: fix a FTBFS because of unuseful
call to GfxFont destructor (virtual and protected) (LP: #383825)

9. By Steve Langasek on 2009-05-01

* Merge from Debian unstable, remaining changes:
  - debian/rules, debian/control: build with g++ -fno-tree-ter on armel,
    instead of build-depending on g++-4.2.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/texlive-bin
This branch contains Public information 
Everyone can see this information.

Subscribers