lp:ubuntu/maverick/splix

Created by James Westby on 2010-05-01 and last modified on 2010-09-22
Get this branch:
bzr branch lp:ubuntu/maverick/splix
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

34. By Till Kamppeter on 2010-09-22

debian/local/pyppd/pyppd/: Updated to pyppd 0.4.9, to suppress runtime
error tracebacks by putting a "try: ... except ...: pass" construct around
the main function call. This avoids SIGPIPE crashes when the execution of
the self-extracting compressed PPD file archives gets stopped by the
calling process (LP: #618017).

33. By Till Kamppeter on 2010-08-11

debian/control: Added dependencies for PPD compression.

32. By Till Kamppeter on 2010-08-11

* debian/local/pyppd/, debian/rules: Compressed all the physical PPD files
  into an archive file reducing the disk space occupation by a factor of 10,
  freeing several megabytes on the Ubuntu Desktop CDs (or on any live CD
  based on Debian or a derivative distribution). The archive is
  self-extracting and located in /usr/lib/cups/driver/, so that CUPS
  automatically extracts the PPD files. Thank you very much to Vitor
  Baptista who developed this great PPD compressor in the Google Summer of
  Code 2010.
* debian/splix.postinst: Updated auto updater for the PPDs of the already
  existing print queues to work with the new PPD archive.

31. By Till Kamppeter on 2010-08-02

New upstream release
o SVN snapshot from August 2, 2010
o New printer supported: Samsung SCX-4521F
o Fixed PPD file version check (LP: #612491).

30. By Till Kamppeter on 2010-08-01

New upstream release
o SVN snapshot from August 1, 2010
o New printers supported: Samsung SCX-4216F, Lexmark X215 MFP, Xerox
WorkCentre PE16
o Set "*FileVersion:" of the PPDs to 2.0.0, to satisfy cupstestppd.
o Fixed "*Product:" lines in the PPDs. They should contain the model
name and not "XXX Ghostscript".

29. By Till Kamppeter on 2010-07-29

* New upstream release
   o SVN snapshot from July 29, 2010
   o New printers supported: Samsung SCX-4100, SCX-4300, ML-2015, ML-2240,
     ML-3051, ML-3051ND, CLP-610ND, SF-565P, Xerox Phaser 3124 (Fixed
     upstream: LP: #505423, LP: #510832)
   o Compiles with GCC 4.5.x (Debian bug #565097).
   o Works with PostScript of the pstops filter of CUPS 1.3.11 and newer.
   o Fixed wrong scanlines in printout.
   o Fixed UI strings for Altitude/Air Pressure option (LP: #605539).
* debian/rules: Let "clean" rule also remove the optimized/ subdirectory
  to not blow up the .diff.gz with irrelevant files.
* debian/rules, debian/local/ppd: Removed extra PPD files. They are
  included upstream now.
* debian/README.Debian: Removed phrase telling that Debian and Ubuntu do
  not contain CUPS DDK. CUPS DDK is included in CUPS since 1.4.x.

28. By Till Kamppeter on 2010-02-13

debian/local/ppd/samsung/clp610nd.ppd,
debian/local/ppd/samsung/clp610ndfr.ppd,
debian/local/ppd/samsung/clp610ndpt.ppd, debian/rules: Added PPDs for
the Samsung CLP-610ND (LP: #505423, LP: #510832).

27. By Till Kamppeter on 2009-09-18

debian/splix.postinst: Fixed "lpstat -r" check for the
auto update of PPDs of existing queues. "lpstat -r" exits always with
status 0, we must check the actual output. Call lpstat, lpadmin, and
cupsctl with "-h /var/run/cups/cups.sock" to avoid querying remote
servers set up in /etc/cups/client.conf, and asking for passwords.
Thanks to Martin-√Čric Racine for tracking this down and the solution!
See Debian bug #543468. Use signal names instead of numbers for trap.
Quiesces a lintian bashism warning.

26. By Till Kamppeter on 2009-06-24

* Merge from debian unstable, remaining changes:
  - XSBC-Original-Maintainer
  - Apport hook

25. By Till Kamppeter on 2009-06-23

* Merge from debian unstable, remaining changes:
  - Depends: cups-client, cups, ghostscript-cups
    (for automatic update of the PPDs of existing print queues and for
    the CUPS part of Ghostscript which is splitted off into its own package)
  - XSBC-Original-Maintainer
  - Apport hook

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/splix
This branch contains Public information 
Everyone can see this information.

Subscribers