lp:ubuntu/maverick/smplayer

Created by James Westby on 2010-04-30 and last modified on 2010-05-09
Get this branch:
bzr branch lp:ubuntu/maverick/smplayer
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

17. By Maia Everett on 2010-05-09

* New upstream release.
* debian/control:
  - Removed mplayer-nogui from Depends, as it is now a transitional package
    to mplayer in both Debian and Ubuntu.
  - Bumped Standards-Version to 3.8.4 (no changes needed).

16. By Maia Everett on 2009-11-21

* debian/compat:
  - Bumped to 7.
* debian/control:
  - Changed maintainer to team.
  - Build-depend on dh 7, no cdbs.
* debian/rules, debian/clean:
  - Rewritten to use dh 7.
  - Set DOC_PATH and remove an unneeded upstream file.
* debian/smplayer.install, debian/smplayer.doc-base:
  - Install upstream docs correctly. (Closes: #557069)
* Dropped debian/README.source - not using CDBS simple-patchsys anymore.

15. By Maia Everett on 2009-11-04

* New upstream release. (Closes: #543156)
* Added /usr/share/pixmaps to debian/menu. (Closes: #526353)
* debian/control: Bumped Standards-Version to 3.8.3.
* debian/rules:
  - Removed VERSION variables, not relevant anymore.
  - Removed dh_desktop.
* Removed 01_gl_translation.patch, fixed upstream.

14. By Maia Everett on 2009-03-31

* New upstream release. (Closes: #523791)
  - Reworked subtitle font preferences. (Closes: #503295)
  - No longer installs qt_fr.qm. (Closes: #486314)
* debian/control:
  - Bumped Standards-Version to 3.8.1.
  - Changed maintainer name (still the same person and GPG key).
  - Changed section to video.
  - Build-depend on zlib1g-dev for findsubtitles.
  - Require Qt >= 4.3 per readme.
  - Added ${misc:Depends}.
  - Make smplayer-translations depend on smplayer and smplayer recommend
    smplayer-translations, not the other way round. (Closes: #489375)
* debian/copyright:
  - Significantly expanded per-file with new upstream authors.
* debian/rules:
  - Make make use correct uic in install.
  - Clean svn_revision.
  - Removed get-orig-source - not needed with uscan --repack.
* debian/patches/01_gl_translation.patch:
  - Added patch to fix lrelease error on smplayer_gl.ts.
* Added debian/README.source for simple-patchsys.

13. By Maia Everett on 2009-01-03

* The "just before FF" release.
* New upstream release.
* debian/control: Bumped Standards-Version to 3.8.0.
* debian/copyright: Changed (C) to © to fix Lintian warning.

12. By Maia Everett on 2008-05-30

* New upstream release.
* Updated get-orig-source rule (again).

11. By Maia Everett on 2008-05-13

* New upstream release.
* Bumped debian/compat to 6.
* debian/control:
  - Require debhelper >= 6.
  - Relaxed the dependency of smplayer-translations on smplayer
    to Recommends. (Closes: #478713)
* Dropped debian/smplayer.desktop, changes applied upstream.

10. By Maia Everett on 2008-04-16

New upstream release.

9. By Maia Everett on 2008-02-15

* Upload to Debian.
* debian/control:
  - Changed maintainer field back.

8. By Maia Everett on 2008-02-14

* The "just before FF" release.
* New upstream release.
* debian/control:
  - Updated upstream homepage (for real this time).
  - Changed maintainer field per Ubuntu policy.
* debian/rules:
  - Added --no-symlink to uscan in get-orig-source to avoid creating
    .orig.tar.bz2 symlinks.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/smplayer
This branch contains Public information 
Everyone can see this information.

Subscribers