lp:ubuntu/maverick-proposed/pyspf

Created by Ubuntu Package Importer on 2012-03-14 and last modified on 2012-03-14
Get this branch:
bzr branch lp:ubuntu/maverick-proposed/pyspf
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

18. By Scott Kitterman on 2012-03-14

Fix issues with false error generation due to CNAMES (LP: #954936

17. By Scott Kitterman on 2009-02-15

[ Sandro Tosi ]
* debian/control
  - switch Vcs-Browser field to viewsvn

[ Scott Kitterman ]
* Upload to unstable
* Add ${misc:Depends} for both binaries

16. By Scott Kitterman on 2009-02-28

No change rebuild for Python 2.6 transition

15. By Scott Kitterman on 2008-07-29

* New upstream release
  - Fall back to TCP if UDP reply is truncated
  - Minor updates for RFC 4408 errata and test suite improvements
* Drop all patches
  - Incorporated upstream
  - Remove simple-patchsys.mk for debian/control
  - Remove patches dir
* Update debian/copyright

14. By Scott Kitterman on 2008-07-01

* Split tools out to spf-tools-python to minimize risk of conflicts between
  SPF related applications using different libraries
  - Add package to debian/control
  - Add spf-tools-python/install to debian/rules
  - Add debian/python-spf.install
  - Move man pages for tools to spf-tools-python.manpages
  - Rename docs to python-spf.docs
  - Add spf-tools-python.docs
  - Split README.Debian for both binaries
  - Move postinst/prerm for update-alternatives to the new package
* Switch to python-central
  - Remove debian/pyversions
  - Update debian/rules
  - Remove debian/pycompat
  - Change build-dep and add XS/XB-Python-Versions to debian/control
  - Install test dir in /usr/share/doc/python-spf to avoid possible
    namespace collisions in site-packages
  - Add DEB_COMPRESS_EXCLUDE += \.py$ \.yml$ to debian/rules so test suite
    is not compressed
* Change Recommends: python-yaml to Suggests: - Test suite is not normally
  run, so python-yaml need not be installed by default
* Update standards version to 3.8.0.1
  - Add debian/README.source
* Properly escape leading quotes in pyspf.1
* Revert inline removal of spf.py shebang and spf-shebang.patch to make
  it right

13. By Michael Vogt on 2008-04-09

* add missing conflicts/replaces to python2.4-spf to
  make dapper->hardy upgrades work
* Modify Maintainer value to match the DebianMaintainerField
  specification.

12. By Scott Kitterman on 2008-03-24

[ Sandro Tosi ]
* debian/control
  - added Vcs-Browser

[ Scott Kitterman ]
* Add tcp-fallback.patch so that truncated UDP DNS replies are retried
  in TCP and either a complete result is fetched or a TempError is raised
* Add trap-command-line-errors.patch so DNS errors don't cause a crash
  when pyspf is used from the command line
* Properly escape hyphens in debian/spfquery.pyspf.1 and
  debian/pyspf-type99.1

11. By Scott Kitterman on 2007-12-08

[ Scott Kitterman ]

* Agreed maintainer change - updated debian/control and debian/copyright
* Really update debian/watch to version 3 (Closes: #453591)
* Remove README.Debian from debian/docs (not needed)
* Move man page installation to python-spf.manpages
* Correct formatting errors in debian/pyspf.1
* Correct formatting errors in debian/spfquery.pyspf.1 and add an example
* Update standards version to 3.7.3 without further change

[ Piotr Ozarowski ]

* Homepage field added
* Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)

[ Philipp Kern ]

* Added `XS-DM-Upload-Allowed: yes' to `debian/control' to allow uploads
  from Debian Maintainers.

10. By Scott Kitterman on 2007-08-01

* New upstream release
  - Upstream changelog date is in error - released 30 Jul 2007
* Update debian/watch to version 3
* Update version numbers in /debian supplied man pages.

9. By Scott Kitterman on 2007-05-15

* debian/control
  - Add python-yaml as recommends for test suite support now that it's
    packaged
* debian/rules
  - Install test directory for test suite
  - Delete obsolete (and commented out) rule for renaming spf.py
* debian/pyspf.1
  - Add instructions for using the pyspf test suite

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/pyspf
This branch contains Public information 
Everyone can see this information.

Subscribers