lp:ubuntu/maverick/launchpad-integration

Created by James Westby on 2010-05-01 and last modified on 2010-08-23
Get this branch:
bzr branch lp:ubuntu/maverick/launchpad-integration
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

45. By Robert Ancell on 2010-08-23

* lib/Makefile.am:
* debian/liblaunchpad-integration-dev.install:
  - Install .vapi file into vala-0.10 directory

44. By Robert Ancell on 2010-08-12

* lib/launchpad-integration.c:
  - Fix memory leak (LP: #483610)

43. By Sebastien Bacher on 2010-08-02

Don't ship the .la files, they create build issues and are not required

42. By Robert Ancell on 2010-05-26

* lib/launchpad-integration.c:
* lib/lpint-bonobo.c:
  - Re-enable bug reporting in Maverick
* lib/launchpad-integration.vapi:
* lib/Makefile.am:
* debian/liblaunchpad-integration-dev.install:
  - Add Vala support
* debian/control:
  - Use Standards-Version 3.8.4
* configure.ac:
  - Bump version

41. By Sebastien Bacher on 2010-04-01

Don't display the report a bug entry in lucid, stable users are encouraged
to use the answer tracker for their issues, technical users who want to
report bugs know how to use ubuntu-bug or launchpad

40. By Chris Halse Rogers on 2010-02-10

* Fix my name in the previous changelog.
* debian/rules:
  - export MONO_DISABLE_SHM to fix build with unwritable $HOME
  - Call dh_clideps in binary-predeb; this runs after the call to
    dh_makeshlibs for liblaunchpad-integration1, and allows dh_clideps to
    resolve dependencies correctly.
  - Update targets for liblaunchpad-integration1.0-cil rename.
  - Pass CSC=/usr/bin/mono-csc for CLI policy conformance.
  - Add $(DEB_CONFIGURE_SCRIPT_ENV) to all calls of the configure script.
* debian/control:
  - Remove manual liblaunchpad-integration1 dependency from
    liblaunchpad-integration1.0-cil. dh_clideps will add this automatically.
  - Rename liblaunchpad-integration1-cil => liblaunchpad-integration1.0-cil
    for Debian CLI policy compliance.
  - Add strict version dependency to liblaunchpad-integration-cil-dev.
    Silences a lintian warning.
* launchpad-integration-sharp.dll.config:
  - Change target from launchpad-integration.so.1 to
    liblaunchpad-integration.so.1 for the benefit of dh_clideps
* debian/liblaunchpad-integration1-cil.install:
* debian/liblaunchpad-integration1-cil.installcligac
  - Rename for liblaunchpad-integration1.0-cil rename.
* debian/patches/01_ltmain_add_as_needed.patch:
  - Patch to fix libtool's handling of --as-needed

39. By Robert Ancell on 2010-02-09

[ Chris Rogers ]
* debian/rules:
  - Revert from DH7 to CDBS and correctly do CLI build

[ Michael Vogt ]
* .bzr-builddeb/default.conf:
  - added with the right options to make it buildable with
    bzr-builddeb out of the box
* debian/rules:
  - removed arch-build target (very pre bzr-builddeb)

38. By Sebastien Bacher on 2010-02-08

Install a dllconfig file so the right library is loaded at runtime
which will fix tomboy not starting for example (lp: #518672)

37. By Robert Ancell on 2010-02-05

* debian/control:
* debian/launchpad-integration-cil-dev.install:
* launchpad-integration-sharp.pc.in:
* Makefile.am:
  - Add launchpad-integration-cil-dev package that contains a pkg-config file
* lib/Makefile.am:
  - Rename from lpi-sharp to launchpad-integration-sharp
* debian/control:
  - Add ${misc:Depends} to liblpint-bonobo-dev

36. By Sebastien Bacher on 2010-01-19

Update translations for the previous change, thank Jeremy Bicha

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/launchpad-integration
This branch contains Public information 
Everyone can see this information.

Subscribers