lp:ubuntu/maverick/gnash

Created by James Westby on 2010-05-01 and last modified on 2010-09-30
Get this branch:
bzr branch lp:ubuntu/maverick/gnash
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

31. By Micah Gersten on 2010-09-28

[ Micah Gersten <email address hidden> ]
* FFe - LP: #636667
* Merge from debian unstable. Remaining changes:
  + Add Ubuntu flash alternatives in postinst and prerm
    - update debian/browser-plugin-gnash.postinst
    - update debian/browser-plugin-gnash.prerm

[ Chris Coulson <email address hidden> ]
* Ensure the directories we are installing alternatives too exist
  already
  - add debian/browser-plugin-gnash.dirs

30. By Sindhudweep Sarkar on 2010-03-08

* new upstream release 0.8.7 (LP: #522254)
  - modified debian/gnash-common.install to ship new library libgnashagg.so.*
  - modified .bzr-builddeb/default.conf to point to new upstream location.
* enable decoding of speex encoded audio
  - modified debian/control.
* fix LP: #318849 - Deprecated klash kde3 binaries removed and not
  replaced with gnash-kde4.
  - modified debian/klash.desktop to point to kde4-gnash binary instead of klash.
  - modified debian/klash.install to install files necessary for kde4-gnash.
  - modified debian/rules to enable the kde4 gui.
  - modified debian/control to include kdelibs5-dev
* fix LP: #322141 - konqueror-plugin-gnash contains no binaries
  - modified debian/konqueror-plugin-gnash.install to install files necessary for the gnash kpart.
  - modified debian/rules to build gnash kpart.

29. By Reinhard Tartler on 2010-01-19

rebuild for ffmpeg versioned symbols

28. By Sindhudweep Sarkar on 2009-10-07

new upstream release 0.8.6 (LP: #435897)

27. By Alexander Sack on 2009-09-11

* fix LP: #422745 - no alternatives for iceape-flashplugin; ignore
  upgrade failures from << 0.8.5-0ubuntu3 (caused by LP: #398213)
  - update debian/mozilla-plugin-gnash.prerm

26. By Chris Coulson on 2009-07-12

* debian/mozilla-plugin-gnash.prerm:
  - Remove redundant "update-alternatives --list" test, which exits with
    an error now when there are no alternatives left. The test doesn't
    return 0 lines anyway, so the check doesn't work. This stops the prerm
    script exiting with an error on removal (LP: #398213).

25. By Sindhudweep Sarkar on 2009-04-03

[ Alexander Sack <email address hidden> ]
* 0.8.5-pre packaging
  - update debian/build_head

[ Sindhudweep Narayan Sarkar <email address hidden> ]
* new upstream release 0.8.5 (LP: #338074)
  - add .bzr-builddeb/default.conf
* ship new lib /usr/lib/gnash/libgnashsound-*.so in gnash-common
  - update debian/gnash-common.install
* removed get-orig-source rule from rules file.
  - update debian/rules
* use bzr upstream
  - deleted debian/watch

24. By Alexander Sack on 2008-10-14

* LP: #84526 - Gnash menu launcher (/usr/share/applications/gnash.desktop
  file) doesn't start any application, also gnash isn't asociated with SWF
  mimetype; we dont show gnash in the .desktop launcher; we add
  NoDisplay=true, add a GenericName and Comment for the sake of
  completeness. Also we add the proper MimeType value, remove Encoding,
  don't use absolute paths for icon and exec and dont use specific icon
  file format suffix.
  - update debian/gnash.desktop

23. By Alexander Sack on 2008-10-13

* new upstream release 0.8.4 (LP: #240325)
* ship new lib usr/lib/gnash/libmozsdk.so.* in mozilla-plugin-gnash
  - update debian/mozilla-plugin-gnash.install
* ship new lib usr/lib/gnash/libgnashnet.so.* in gnash-common
  - update debian/gnash-common.install
* add basic debian/build_head script to build latest CVS head packages.
  - add debian/build_head
* new sound architecture requires build depend on libsdl1.2-dev
  - update debian/control
* head build script now has been completely migrated to bzr (upstream +
  ubuntu)
  - update debian/build_head
* disable kde gui until klash/qt4 has been fixed; keep kde packages as empty
  packages for now.
  - update debian/rules
  - debian/klash.install
  - debian/klash.links
  - debian/klash.manpages
  - debian/konqueror-plugin-gnash.install
* drop libkonq5-dev build dependency accordingly
  - update debian/control
* don't install headers manually anymore. gnash doesnt provide a -dev
  package after all
  - update debian/rules
* update libs installed in gnash-common; libgnashserver-*.so is not available
  anymore (removed); in turn we add the new libgnashcore-*.so
  - update debian/gnash-common.install
* use -Os for optimization and properly pass CXXFLAGS=$(CFLAGS) to configure
  - update debian/rules
* touch firefox .autoreg in postinst of mozilla plugin
  - update debian/mozilla-plugin-gnash.postinst
* link gnash in ubufox plugins directory for the plugin alternative switcher
  - add debian/mozilla-plugin-gnash.links
* suggest ubufox accordingly
  - update debian/control
* add new required build-depends on libgif-dev
  - update debian/control
* add Xb-Npp-Description and Xb-Npp-File as new plugin database meta data
  - update debian/control
* bump minimum version for automake to >= 1.10
  - update debian/control

22. By Alexander Sack on 2008-10-13

* new upstream release 0.8.4 (LP: #240325)
* ship new lib usr/lib/gnash/libmozsdk.so.* in mozilla-plugin-gnash
  - update debian/mozilla-plugin-gnash.install
* ship new lib usr/lib/gnash/libgnashnet.so.* in gnash-common
  - update debian/gnash-common.install
* add basic debian/build_head script to build latest CVS head packages.
  - add debian/build_head
* new sound architecture requires build depend on libsdl1.2-dev
  - update debian/control
* head build script now has been completely migrated to bzr (upstream +
  ubuntu)
  - update debian/build_head
* disable kde gui until klash/qt4 has been fixed; keep kde packages as empty
  packages for now.
  - update debian/rules
  - debian/klash.install
  - debian/klash.links
  - debian/klash.manpages
  - debian/konqueror-plugin-gnash.install
* drop libkonq5-dev build dependency accordingly
  - update debian/control
* don't install headers manually anymore. gnash doesnt provide a -dev
  package after all
  - update debian/rules
* update libs installed in gnash-common; libgnashserver-*.so is not available
  anymore (removed); in turn we add the new libgnashcore-*.so
  - update debian/gnash-common.install
* use -Os for optimization and properly pass CXXFLAGS=$(CFLAGS) to configure
  - update debian/rules
* touch firefox .autoreg in postinst of mozilla plugin
  - update debian/mozilla-plugin-gnash.postinst
* link gnash in ubufox plugins directory for the plugin alternative switcher
  - add debian/mozilla-plugin-gnash.links
* suggest ubufox accordingly
  - update debian/control
* add new required build-depends on libgif-dev
  - update debian/control
* add Xb-Npp-Description and Xb-Npp-File as new plugin database meta data
  - update debian/control

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/gnash
This branch contains Public information 
Everyone can see this information.

Subscribers