lp:ubuntu/maverick/cups

Created by James Westby on 2010-05-01 and last modified on 2010-10-01
Get this branch:
bzr branch lp:ubuntu/maverick/cups
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

41. By Martin Pitt on 2010-09-29

ubuntu-upstart.dpatch: If D-BUS is not available, start on runlevels 2 to
5, so that this also works in server environments. Patch cherrypicked from
packaging trunk. (LP: #650893)

40. By Martin Pitt on 2010-09-27

* ubuntu-upstart.dpatch: Wait until daemon is ready, to avoid race
  conditions with init scripts which expect cups tools to work right after
  restarting it. This fixes a regression from the upstartification.
  Patch cherrypicked from packaging trunk. (LP: #647369)
* debian/control: Update Vcs-Bzr: for Maverick branch.

39. By Martin Pitt on 2010-09-23

debian/cups.preinst: Go back to using lsb-release, since dpkg-vendor is
not installed by default (it's in dpkg-dev). Bump the version guard to
this version, to reattempt the migration. (LP: #645328)

38. By Martin Pitt on 2010-09-16

[ Martin Pitt ]
* ubuntu-upstart.dpatch: Drop the dependency "on starting smbd", it causes
  samba to hang on package upgrades or manual restarts. There doesn't seem
  to be a good way to express this dependency right now. (LP: #639768)
  Instead, send a SIGHUP to smbd if it is running, which causes it to reload
  printers.

[ Till Kamppeter ]
* pstops-based-workflow-only-for-printing-ps-on-a-ps-printer.dpatch:
  Let CUPS use the former PostScript-based filter chain only if the input
  file is PostScript and the printer is a PostScript printer with
  manufacturer-supplied PPD file. This avoids ugly PS->PDF->PS conversions
  which are bad for the performance and sometimes cause issues
  (Closes: #593338, requested by Ricoh).

37. By Martin Pitt on 2010-09-16

ubuntu-upstart.dpatch: Drop the dependency "on starting smbd", it causes
samba to hang on package upgrades or manual restarts. There doesn't seem
to be a good way to express this dependency right now. (LP: #639768)

36. By Martin Pitt on 2010-09-14

[ Till Kamppeter ]
* default-ripcache-size-auto.dpatch: Replaced patch for letting CUPS default
  RIP_MAX_CACHE to 1/4 of the system's RAM by a patch defaulting
  RIP_MAX_CACHE to "auto". See LP: #628030.
* debian/patches/cups-snmp-oids-device-id-hp-ricoh.dpatch: Let the "snmp"
  backend also use the manufacturer-specific MIBs of HP and Ricoh to
  obtain the device IDs of network-connected printers. This way we get more
  reliable information about make and model and in addition the supported
  page description languages, which allow to identify whether an optional
  PostScript add-on is installed or for an unsupported printer which
  generic PPD is the best choice (requested by Ricoh, thanks to Tim Waugh
  from Red Hat to create the patch).

[ Martin Pitt ]
* debian/control: Drop perl-modules dependency. The only script that uses
  perl is oopstops, which uses IO::Handle, and this is in perl-base.
* debian/control, debian/rules, ubuntu-*.dpatch: Replace lsb_release call
  with dpkg-vendor, and drop lsb-release build dependency.
* Upstartify for Ubuntu:
  - Add ubuntu-upstart.dpatch: Add debian/cups.upstart script, which now
    causes Samba to wait for cups to start. Don't have it in debian/ by
    default, since dh_installinit unconditionally prefers it over .init.
  - debian/rules: Call dh_installinit with --upstart-only when building on
    Ubuntu.
  - debian/cups.preinst: Remove old init script on upgrades when running on
    Ubuntu.
* debian/cups.preinst: Remove some obsolete transitional code.
* debian/cups.init.d, debian/cups.postinst: Move custom PPD directory setup
  from init script into postinst. No need to do that on every boot.

35. By Till Kamppeter on 2010-09-10

* debian/patches/cups-snmp-oids-device-id-hp-ricoh.dpatch: Let the "snmp"
  backend also use the manufacturer-specific MIBs of HP and Ricoh to
  obtain the device IDs of network-connected printers. This way we get more
  reliable information about make and model and in addition the supported
  page description languages, which allow to identify whether an optional
  PostScript add-on is installed or for an unsupported printer which
  generic PPD is the best choice (requested by Ricoh, thanks to Tim Waugh
  from Red Hat to create the patch).
* debian/patches/non-ubuntu-dynamic-default-ripcache-size.dpatch,
  debian/patches/ubuntu-default-ripcache-size-auto.dpatch,
  debian/patches/default-ripcache-size-auto.dpatch: Let RIP_MAX_CACHE
  default to "auto" in Ubuntu AND Debian. Debian's Ghostscript also
  has the patch for automatic memory management for the CUPS Raster
  output device.

34. By Till Kamppeter on 2010-09-02

[ Till Kamppeter ]
* debian/patches/dynamic-default-ripcache-size.dpatch,
  debian/patches/non-ubuntu-dynamic-default-ripcache-size.dpatch,
  debian/patches/ubuntu-default-ripcache-size-auto.dpatch:
  Replaced patch for letting CUPS default RIP_MAX_CACHE to 1/4 of the
  system's RAM by a patch defaulting RIP_MAX_CACHE to "auto" only in
  Ubuntu as there we have a Ghostscript version which managers its
  needed memory size automatically. In non-Ubuntu distributions we stay
  with the 1/4 of system RAM patch.

[ Martin Pitt ]
* debian/control: Drop perl-modules dependency. The only script that uses
  perl is oopstops, which uses IO::Handle, and this is in perl-base.

33. By Martin Pitt on 2010-08-11

[ Jamie Strandboge ]
* debian/cups.post{inst,rm}: update for local include file
* debian/local/apparmor-profile: add local include file

[ Martin Pitt ]
* debian/rules: Stop building with --enable-threads, since currenu GnuTLS
  does not work with threads. This brings back the lost SSL/TLS support.
  (Closes: #588234, #591509)
* debian/libcups2.symbols: Readd _http{Read,Write}GNUTLS@Base symbols to
  ensure that autogenerated shlibs dependencies for libcups get tight
  enough.
* manpage-translations.dpatch: Update German manpage translations, thanks
  Helge Kreutzmann! (Closes: #588028)
* debian/rules: Set DPKG_GENSYMBOLS_CHECK_LEVEL to 4 to point out outdated
  .symbols files more strongly.
* debian/libcups2.symbols, debian/libcupsimage2.symbols: Subsume private
  optional symbols into regexps.

32. By Jamie Strandboge on 2010-08-06

* debian/cups.post{inst,rm}: update for local include file
* debian/local/apparmor-profile: add local include file

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/cups
This branch contains Public information 
Everyone can see this information.

Subscribers