lp:ubuntu/lucid/php5

Created by James Westby on 2009-10-30 and last modified on 2010-04-09
Get this branch:
bzr branch lp:ubuntu/lucid/php5
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

63. By Chuck Short on 2010-04-05

debian/control, debian/rules: Re-enable libedit-dev. (LP: #548823)

62. By Chuck Short on 2010-03-28

debian/control: Fix upgrade of php5-ldap from 5.3.1. (LP: #)

61. By Chuck Short on 2010-03-26

debian/control: Dont build with libmcrypt-dev.

60. By Chuck Short on 2010-03-16

* Merge from debian unstable:
  - debian/control:
    * Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
    * Dropped libmysqlclient15-dev, build against mysql 5.1.
    * Dropped libcurl-dev not in the archive.
    * Suggest php5-suhosin rather than recommends.
    * Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions already in
      universe.
    * Dropped libonig-dev and libqgdbm since its in universe. (will be re-added in lucid+1)
    * Dropped locales-all.
  - modulelist: Drop imap, interbase, and mcrypt.
  - debian/rules:
    * Dropped building of mcrypt, imap, and interbase.
    * Install apport hook for php5.
  - Dropped debian/patches/libedit_is_editline.patch.

59. By Chuck Short on 2010-03-22

debian/patches/libedit_is_editline.patch: Updated for PHP 5.3.2 (LP: #543212)

58. By Chuck Short on 2010-02-24

* Upload to lucid:
  - debian/control:
   * Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
   * Dropped libmysqlclient15-dev, build against mysql 5.1.
   * Dropped libcurl-dev not in the archive
   * Suggest php5-suhosin rather than recommends.
   * Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions already in
     universe
   * Dropped locales-all.
  - modulelist: Drop imap, internabse, and mcrypt.
  - debian/rules:
    + Dropped building of mycrypt, imap, and interbase.
    + Install apport hook for php5, apart of the server-lucid-apport-hooks.
  - debian/patches/libedit_is_editline.patch: Refreshed.

57. By Chuck Short on 2010-02-04

debian/control: Fix FTBFS.

56. By Chuck Short on 2010-01-26

* Merge from debian testing. Remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mcrypt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - main/php_version.h: updated with Ubuntu version info
  - debian/patches/series: Re-enable the 033-we_WANT_libtool.patch patch
  - debian/rules, debian/source_php5.py: Install apport hook.
* Dropped patches: CVE-2009-3557.patch and CVE-2009-3558.patch, no longer needed.

55. By Chuck Short on 2010-01-19

debian/rules, debian/source_php5.py: Install apport hook.

54. By Marc Deslauriers on 2009-11-30

* Merge from debian unstable, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mcrypt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - main/php_version.h: updated with Ubuntu version info
* debian/patches/series: Re-enable the 033-we_WANT_libtool.patch patch
* debian/patches/sybase-alias.patch: use the debian patch
* Dropped unapplied patches: fix_64bit_time.patch,
  fix-autoconf-ftbfs.patch, 027-readline_is_editline.patch,
  deprecated_freetds_check.patch, use-specific-libdb-version.patch,
  CVE-2008-5625.patch.
* SECURITY UPDATE: safe_mode bypass via tempam function
  - debian/patches/CVE-2009-3557.patch: check for safe_mode in
    ext/standard/file.c.
  - CVE-2009-3557
* SECURITY UPDATE: open_basedir restrictions bypass via posix_mkfifo
  - debian/patches/CVE-2009-3558.patch: check for open_basedir in
    ext/posix/posix.c.
  - CVE-2009-3558

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/maverick/php5
This branch contains Public information 
Everyone can see this information.

Subscribers