lp:ubuntu/lucid-security/mutt

Created by Ubuntu Package Importer on 2012-04-11 and last modified on 2014-12-10
Get this branch:
bzr branch lp:ubuntu/lucid-security/mutt
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

31. By Steve Beattie on 2014-12-10

* SECURITY UPDATE: heap-based overflow in mutt_substrdup() when
  handling headers beginning with newline.
  - debian/patches/ubuntu/mutt-CVE-2014-9116.patch
  - CVE-2014-9116

30. By Steve Beattie on 2014-03-12

* SECURITY UPDATE: buffer overflow in header processing after
  address expansion.
  - debian/patches/ubuntu/mutt-CVE-2014-0467.patch
  - CVE-2014-0467

29. By Tyler Hicks on 2011-09-22

* SECURITY UPDATE: Failure to verify that a server's hostname matches the
  Common Name listed in a certificate when setting up a TLS connection.
  - debian/patches/ubuntu/CVE-2011-1429.patch: Verify the peer's certificate.
  - CVE-2011-1429

28. By James Westby on 2010-02-23

Merge with Debian testing.

27. By Mathias Gug on 2010-01-20

debian/control, debian/patches/debian-specific/build_doc_adjustments.diff:
use w3m instead of elinks for generating documentation.

26. By Antonio Radici on 2009-12-02

* debian/patches:
  + upstream/533370-pgp-inline.patch: fixing the patch from 1.5.20-3, now
    pgp.c is correctly included (Closes: 533370, 558813)
  + upstream/537694-segv-imap-headers.patch: fixing a segfault when the IMAP
    server sends additional headers and mutt segfaults (Closes: 537694)
  + upstream/393926-internal-viewer.patch: revert the patch and add the
    auto_view of text/x-diff (Closes: 546760, 549158)
  + upstream/548577-gpgme-1.2.patch: do not fail to open pgp signed message
    with libgpgme >= 1.2 (Closes: 548577)

25. By Steve Langasek on 2009-10-02

Revert upstream/393926-internal-viewer.patch, which introduces
regressions in the support for all text/types that have interactive
external handlers in mailcap (e.g., text/html). The regression is being
tracked as Debian bug #546760.

24. By Antonio Radici on 2009-09-14

Backing out the broken mutt-patched/sidebar-newonly patch
(Closes: 546591, 546592)

23. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-06-27

Merge from debian unstable (LP: #392997), remaining changes:
debian/control: Recommend default-mta instead of exim4.

22. By أحمد المحمودي (Ahmed El-Mahmoudy) on 2009-06-17

* Merge from debian unstable (LP: #388515)
* Build-depend on elinks-lite
  + elinks-lite doesn't provide links anymore.
  + elinks-lite is now in main, and pulls less dependencies than the
    full-fledged elinks.
* debian/control: Recommend default-mta instead of exim4. (LP: #386308)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/precise/mutt
This branch contains Public information 
Everyone can see this information.

Subscribers