lp:ubuntu/lucid-updates/graphviz

Created by Ubuntu Package Importer on 2014-01-16 and last modified on 2014-12-04
Get this branch:
bzr branch lp:ubuntu/lucid-updates/graphviz
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

33. By Seth Arnold on 2014-12-04

* SECURITY UPDATE: Format string vulnerability may allow attackers to
  cause a denial of service or possibly execute code.
  - debian/patches/CVE-2014-9157.patch: Fix format string vulnerability in
    lib/cgraph/scan.l yyerror() routine.
  - CVE-2014-9157

32. By Marc Deslauriers on 2014-01-14

* SECURITY UPDATE: buffer overflow in yyerror()
  - debian/patches/CVE-2014-0978.patch: don't overflow buf in
    lib/cgraph/scan.l.
  - CVE-2014-0978
* SECURITY UPDATE: buffer overflow in yyerror() security fix
  - debian/patches/CVE-2014-1235.patch: once again, don't overflow buf
    in lib/cgraph/scan.l.
  - CVE-2014-1235
* SECURITY UPDATE: buffer overflow in chkNum of scanner
  - debian/patches/CVE-2014-1236.patch: don't overflow buf in
    lib/cgraph/scan.l.
  - CVE-2014-1236

31. By Chuck Short on 2010-03-02

Rebuild for php 5.3.

30. By Luke Yelavich on 2010-02-19

No-change rebuild for OCaml 3.11.2 transition (LP: #522363).

29. By Matthias Klose on 2010-02-01

* Merge with Debian; remaining changes:
  - Fix a segfault in dot2gxl.
  - debian/control: Added XS-Python-Version: all
* debian/rules:
  - Included python.mk
  - Load PYTHON_VERSIONS with default version instead of all versions
  - Enable generic python support in configure (parameter --enable-python)
    call and disable python2.5 (--enable-python25) support.
  - Install the generic python support.

28. By James Westby on 2009-09-16

Fix a segfault in dot2gxl.

27. By Jonathan Riddell on 2009-07-28

No change rebuild against current OCaml. (LP: #405286)

26. By Martin Pitt on 2009-06-15

No-change rebuild against current OCaml. (LP: #383574)

25. By Fabrice Coutadeur on 2009-03-26

* debian/control:
  - Dropped build dependency on python2.4-dev
  - Added build dependency on python2.6-dev (LP: #338553)
  - Added XS-Python-Version: all
  - Updated description of libgv-python to drop references to python2.4 and
    python2.5
* debian/rules:
  - Included python.mk
  - Load PYTHON_VERSIONS with default version instead of all versions
  - Enable generic python support in configure (parameter --enable-python)
    call and disable python2.4 (--enable-python24) support
  - Install the generic python support and 2.5 support instead of 2.4 and 2.5

24. By Martin Pitt on 2008-11-05

* Merge with Debian unstable; remaining Ubuntu changes:
  - Build against guile 1.8 instead of 1.6. (forwarded to Debian #493974)
  - Fix gs-common build dependency to ghostscript. (forwarded to
    Debian #504569)
  - Update build dep libltdl3-dev to libltdl7-dev. (forwarded to
    Debian #504571)
* Build against lua 5.1 instead of 5.0. This drops this Debian delta and
  moves Ubuntu towards the newer lua version, which we need to do at some
  point anyway.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/trusty/graphviz
This branch contains Public information 
Everyone can see this information.

Subscribers