lp:ubuntu/karmic/language-selector

Created by James Westby on 2009-07-04 and last modified on 2009-10-23
Get this branch:
bzr branch lp:ubuntu/karmic/language-selector
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

78. By Colin Watson on 2009-10-23

* Use dictionary-based format string substitution for "%d to install" and
  "%d to remove" (now "%(INSTALL)d to install" and "%(REMOVE)d to
  remove"), so that gnome-language-selector doesn't crash when a
  translation intentionally uses fixed strings for some of its plural
  forms (LP: #409785).
* Remove fuzzy markers on the respective Arabic and Hebrew translations
  (see 0.4.16) since they no longer cause a crash.

77. By Michael Vogt on 2009-10-21

* LanguageSelector/LocaleInfo.py:
  - when running without the LANGUAGE environment, do not
    witch to english half-way through (LP: #457235)

76. By Colin Watson on 2009-10-20

* Add --show-installed option to check-language-support, so that ubiquity
  can arrange to keep language support packages installed that are already
  present in the live filesystem.
* Enable translation for check-language-support.
* Mark Arabic translations of "%d to install" and "%d to remove" as fuzzy,
  until such time as they're corrected in Launchpad (LP: #409785).
* ... and likewise for Hebrew (LP: #363990).

75. By Arne Goetje on 2009-10-20

* Added fa_AF and kk translations
* Fix display of the Details box in gnome-language-selector (Thanks to
  Markus Korn) (LP: #455370)

74. By Arne Goetje on 2009-10-19

* add workaround to enable translations (LP: #425368)
* Update translations from Launchpad

73. By Colin Watson on 2009-10-14

* Fix typo in check-language-support(1) that caused a Lintian warning.
* Print nothing rather than a blank line if check-language-support finds
  no missing packages.

72. By Arne Goetje on 2009-10-14

* Add openoffice.org-help-* and evolution-documentation-* to the
  package dependencies (Thanks to Timo Jyrinki) (LP: #414753)
* add /usr/bin/check-language-support to query missing packages for a
  given language code or all installed languages (LP: #434173)
* LanguageSelector/LangInfo.py: don't crash if langcode is not in the
  ISO639 list (LP: #439728)

71. By Arne Goetje on 2009-09-17

* Fix crash in gnome-language-selector (LP: #427716)
* Fall back to 'en_US' locale if none has been defined or has been set
  to 'C'. (LP: #386029) (LP: #346363) (LP: #347240)
* Fix crash when ~/.xinput/ is not present (LP: #219218)
* Add manpage for gnome-language-selector (Thanks to Alex Lourie)
 (LP: #426642)
* Fix typo in LanguageSelector/FontConfig.py (LP: #219398)
* data/languagelist: add fallback codes for all English variations we
  have as locales (LP: #47280) (LP: #72952)
* Update translations from Launchpad
* Really remove now obsolete Chinese entry from language list
  (LP: #431228)

70. By Harald Sitter on 2009-09-13

Fix crash in Qt's uninstall mode

69. By Harald Sitter on 2009-09-10

* Implement input method subsystem into Qt UI
* Make the Qt UI's uninstall mode more usable by hiding not-installed
  languages from the list view
* Port package build system to dh 7
  + Build-depend on debhelper 7
* Bump standards version to 3.8.3
* Add misc depends to all packages
* Revise copyright file
* Add manpage for qt-lanaguage-selector (as produced by kdemangen.pl)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/language-selector
This branch contains Public information 
Everyone can see this information.

Subscribers