lp:ubuntu/karmic/emacsen-common

Created by James Westby on 2009-07-02 and last modified on 2009-11-06
Get this branch:
bzr branch lp:ubuntu/karmic/emacsen-common
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

5. By Loïc Minier on 2009-10-26

emacs-package-install: don't throw an error when maintainer scripts call
this hook while emacsen-common isn't yet configured; LP: #456523.

4. By Rob Browning <email address hidden> on 2009-05-17

* Move the sample package install/remove scripts from
  debian-emacs-policy to the files sample-package-install-foo and
  sample-package-remove-foo in /usr/share/doc/emacsen-common.

* Fix some suspicious code in the sample package install/remove scripts.
  Thanks to Kevin Ryde <email address hidden>. (closes: 424940)

* Update debian-file->string to use insert-file-contents-literally.
  Change gnus-nntpserver-file defvar to setq. Thanks to Jari Aalto
  <email address hidden>. (closes: 269155)

* Always call debian-run-directories. Previously a bug would prevent it
  from running if debian-emacs-flavor wasn't set. Thanks to Francesco
  Potorti` <email address hidden> and Andrew Kemp <email address hidden>.
  (closes: 222518, 136779)

* Thanks to Agustin Martin Domingo <email address hidden> for collecting
  and incorporating many of the fixes in the previous release, this
  release, and probably the next several releases into his git
  repository. That work is being used heavily as a reference during
  these updates.

3. By Rob Browning <email address hidden> on 2006-01-05

* Remove "Conflicts: emacs". If I recall correctly, this dates back to
  a time when the Emacs binary package was just named "emacs"
  (i.e. unversioned), and before the creation of emacsen-common and the
  Debian Emacs Policy. The Conflicts should be safe to remove now, and
  the removal will allow us to create a new emacs-defaults source
  package (a la gcc-defaults) that will produce an emacs package that
  always depends on the current "standard" version of Emacs
  (i.e. emacs21, emacs22, etc.).
* Update to Standards-Version to 3.6.2.

2. By Rob Browning <email address hidden> on 2005-01-27

* Fix sarge RC bug. Alter debian-pkg-add-load-path-item to handle nil
  in load-path. Thanks to Manoj Srivastava. (closes: 270388)
* Include section and priorty in dpkg-gencontrol generated control file.
  (closes: 288752)
* Don't create /usr/doc/ symlinks anymore.
* Remove pause in 00debian-vars.el when there is no /etc/mailname. The
  message will always be available in *Messages*. The real fix for this
  may involve bug 149924. (closes: 115116)
* Ignore *~ when generating package list. Eventually we may do
  something more like run-parts, but this is at least an improvement.
  (ref: #29494)
* Make the package description a bit more elaborate. (closes: 209469)
* Fix debian-emacs-policy typo. (closes: 175779)

1. By Rob Browning <email address hidden> on 2002-02-18

* make /etc/emacs/site-start.d/00debian-vars.el a conffile as per Debian
  policy. (closes: Bug#132842)
* don't use dolist (not defined everywhere by default).
  (closes: Bug#132352)
* document debian-pkg-add-load-path-item better and fix to actually
  modify load-path. (closes: Bug#134464)
* make debian-unique-strings iterative since elisp isn't as recursion
  friendly as we might like. (closes: Bug#131803)
* for now, issue a descriptive error message if emacsen-common is used
  before it's configured.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/emacsen-common
This branch contains Public information 
Everyone can see this information.

Subscribers