lp:ubuntu/karmic/amsn

Created by James Westby on 2009-08-06 and last modified on 2009-11-06
Get this branch:
bzr branch lp:ubuntu/karmic/amsn
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

33. By Devid Antonio Filoni on 2009-10-22

* New upstream release (LP: #458159), source tarball repacked as described
  in debian/README.Debian-source.
* debian/rules: don't remove plugins/amsnplus/snapshot binary anymore.

32. By Devid Antonio Filoni on 2009-08-26

* debian/rules: remove plugins/amsnplus/snapshot binary before build,
  fix FTBFS.
* debian/control: add libgupnp-igd-1.0-dev to Build-Depends field.

31. By Devid Antonio Filoni on 2009-08-26

* New upstream release, tarball repacked according to
  debian/README.Debian-source.
* Remove debian/patches/{09_libv4l_svn10551, 10_svn10639, 11_svn10867,
  12_svn11166, 07_autoupdate, 08_proxy, 06_TkCximage, 04_use_xdg-open}.dpatch
  patches, merged upstream.
* Regenerate debian/patches/{04_settingoff_autoupdate,
  08_use_aplay_for_sound}.dpatch patches.
* Remove not-applied debian/patches/05_changing_sxml.dpatch patch.
* Remove useless debian/messenger.xpm file.
* debian/rules: remove -DHAVE_LIBV4L from CFLAGS and -lv4l2 from LDFLAGS.
* debian/control: add libgstfarsight0.10-dev and
  libgstreamer-plugins-base0.10-dev to Build-Depends field.
* debian/control: add gstreamer0.10-nice to Depends field.
* Bump Standards-Version to 3.8.3.
* Fix dh_desktop-is-deprecated lintian warning.
* Fix duplicate-long-description lintian info.
* Fix patch-system-but-no-source-readme lintian warning.

30. By petski on 2009-05-07

Load proxy.tcl before plugins.tcl to make sure the correct version of the
http package is loaded before any plugins start loading some incompatible
version (LP: #371103). Thanks to aMSN developer KaKaRoTo

29. By Adrien Cunin on 2009-04-08

debian/rules: added -lv4l2 to LDFLAGS for libv4l support to work correctly,
fixes LP: #314805

28. By Adrien Cunin on 2009-04-03

* Merge from Debian unstable, fixes login issue with tcl 8.5.6 (LP: #352814)
  Remaining Ubuntu changes:
   - Added patch 04_use_xdg-open, added xdg-utils dependency
   - Added patch 08_use_aplay_for_sound
   - Added libv4l support: build-dep on libv4l, add -DHAVE_LIBV4L to CFLAGS,
     add patch 09_libv4l_svn10551
   - Added patches 10_svn10639 and 11_svn10867
   - debian/control: iceweasel -> firefox | abrowser, sox -> alsa-utils

27. By Devid Antonio Filoni on 2009-01-29

Add 11_svn10867.dpatch from upstream svn to fix an issue with v4l1 webcams
not working with v4l2. Fix LP: #260918.

26. By Devid Antonio Filoni on 2008-11-26

* Add support for libv4l (LP: #260918):
  - add libv4l-dev (>= 0.5.0) to Build-Depends field in debian/control
  - add debian/patches/09_libv4l_svn10551.dpatch patch from upstream svn,
    this makes libng use libv4l2 for webcam palette conversion and access
  - debian/rules: add -DHAVE_LIBV4L to CFLAGS; 09_libv4l_svn10551.dpatch
    patch doesn't contain the changes included in r10551 to Makefile and
    configure{,.ac}
* add debian/patches/10_svn10639.dpatch patch from upstream svn, this
  contains a fix from Fedora to utils/linux/capture/libng/plugins/drv0-v4l2.c
  file.

25. By Devid Antonio Filoni on 2008-11-17

* Merge from Debian unstable, remaining Ubuntu changes:
  - add 04_use_xdg-open.dpatch patch to use xdg-open as file manager
  - add 08_use_aplay_for_sound.dpatch patch by Festor Wailon Dacoba to use
    aplay to play sounds
  + debian/control:
    - modify iceweasel to firefox | abrowser in amsn Suggests field
    - add xdg-utils to amsn Depends field
    - mofify sox to alsa-utils in amsn Suggests field as we are now using
      aplay

24. By Fabien Tassin on 2008-09-21

* fix LP: #272772: packages that Depend/Recommend/Suggest firefox
  (meta-package) must alternatively Depend/Recommend/Suggest abrowser
  - update debian/control

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/amsn
This branch contains Public information 
Everyone can see this information.

Subscribers