lp:ubuntu/karmic/amarok

Created by James Westby on 2009-07-25 and last modified on 2009-10-08
Get this branch:
bzr branch lp:ubuntu/karmic/amarok
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

101. By Jonathan Riddell on 2009-10-08

Add 04_lyrics_script.diff from upstream, remove adverts in lyrics

100. By Christian Mangold on 2009-09-28

New upstream release

99. By Christian Mangold on 2009-09-22

* New upstream release candidate
* Move libqt4-sql-sqlite from Suggests to Recommends (LP: #430105)
* Remove 'override_dh_strip: true' from debian/rules (LP: #433325)
* Update amarok.install and amarok-common.install
* Bump version of build-deps, libtag1-dev to 1.6 and libtag-extras-dev
  to 1.0.1, new versions are required now

98. By Christian Mangold on 2009-09-14

* New upstream beta release
  - Fixes cover download (LP: #335578)
* Remove 05_fix_lyrics_script.diff, fixed upstream (LP: #409407)
* Remove 04_gpod_compile.diff, fixed upstream

97. By Jonathan Riddell on 2009-09-03

New upstream beta release

96. By Michael Casadevall on 2009-09-02

[ Christian Mangold ]
* Add patch 05_fix_lyrics_script.diff to make the lyrics
  script work again (LP: #409407)

[ Michael Casadevall ]
* debian/control:
  - Changed build-deps to depend on gtk version of libgpod so kpiti-plugins
    and other packages depending on the gtk version can co-exist.

95. By Harald Sitter on 2009-08-26

Create mysqle directory manually (for some reason we get to dh_install
before dh_installdirs?)

94. By Jonathan Riddell on 2009-08-25

rebuild with latest pkg-kde-tools to make sure it gets installdocs
right

93. By Jonathan Riddell on 2009-08-24

[ Jonathan Thomas ]
* Merge from Debian Unstable, remaining changes:
  - Build-depend on cdbs
  - Build-depend on libgpod-nogtk-dev | libgpod-dev
  - Keep conflicts/replaces on amarok-kde4* packages
  - Amarok replaces amarok-common (<< 2:2.1.1orig-0ubuntu2) 'til karmic+1
  - amarok-common replaces mysql-server-data-5.1 until karmic+1
  - Keep the following patches:
    + kubuntu_03_restricted_install.diff
    + kubuntu_04_gpod_compile.diff

[ Jonathan Riddell ]
* Build-dep on pkg-kde-tools 0.4.11ubuntu4 which has i18n support for
  debhelper 7

92. By Harald Sitter on 2009-08-18

* Redo tarball without MySQL (5.1 now in main => migrating to that)
* Drop all the MySQL-related stuff (build rules, copyright, deps...)
  + Remove debian/patches-mysql
  + Rename debian/patches-amarok to debian/patches
  + remove source.lintian-overrides (only conained mysql stuff
* Use CDBS
* Amarok package now depends mysql-server-core-5.1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/amarok
This branch contains Public information 
Everyone can see this information.

Subscribers