Ubuntu

lp:ubuntu/intrepid-updates/update-manager

Created by James Westby on 2010-02-22 and last modified on 2010-02-22
Get this branch:
bzr branch lp:ubuntu/intrepid-updates/update-manager
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

191. By Michael Vogt on 2008-11-04

* UpdateManager/UpdateManager.py:
  - simply the changelog download logic and make changelog
    fetching work properly again (now that the server side
    got improved as well) LP: #40058

190. By Michael Vogt on 2008-11-04

[ Michael Vogt ]
* DistUpgrade/DistUpgradeQuirks.py:
  - add detection for cards no longer supported via fglrx
    and ensure transition to "ati" (LP: #284408)
* DistUpgrade/DistUpgradeCache.py:
  - check if the package is actually downloadable in the
    removal blacklist checking (LP: #293486)

[ Jonathan Riddell ]
* DistUpgrade/DistUpgradeViewKDE.py:
  - handle translations of non-ascii string on Cancel button
    correctly (LP: #291115)

189. By Michael Vogt on 2008-10-24

* DistUpgrade/DistUpgradeQuirks.py:
  - when transitioning from kubuntu-kde4-desktop to kubuntu-desktop
    consider key dependencies as well even if kubuntu-kde4-desktop
    is no longer installed (LP: #277285)

188. By Michael Vogt on 2008-10-24

* DistUpgrade/DistUpgrade.cfg:
  - remove goubuntu-desktop from metapackages, we do no
    longer build it (LP: #283712)
* DistUpgrade/DistUpgradeCache.py:
  - never remove packages in the "KeepInstalled" section
  - keep the GUI alive when calculating the packages
    to cleanup
* DistUpgrade/DistUpgradeQuirks.py:
  - mark "language-pack-$lang" as manual installed to
    workaround changes in "language-support-$lang"
    (LP: #287551)
 * po/:
   - updated to the latest translations.launchpad.net
     version

187. By Michael Vogt on 2008-10-23

* DistUpgrade/DistUpgradeViewText.py:
  - ignore "default" argument handling in askYesNoQuestion
    to fix incorrect prompt for cdrom question
* DistUpgrade/DistUpgradeQuirks.py:
  - ensure "landscape-common" is not marked auto-install
    (LP: #288051)
* DistUpgrade/ReleaseAnnouncement:
  - updated for final release
* DistUpgrade/DistUpgradeAptCdrom.py:
  - ignore "dist-upgrader" dirs when scanning for
    packages (LP: #288169)

186. By Michael Vogt on 2008-10-20

fix incorrect case and typo in cpuHasSSESupport(), thanks
to Steve Langasek

185. By Michael Vogt on 2008-10-20

* DistUpgrade/DistUpgradeQuirks.py:
  - do not install nvidia-glx-{173,177} on systems without
    the "sse" cpu extension (LP: #272498)
  - fix case-sensitive parsing when checking for the xorg
    driver
* DistUpgrade/DistUpgrade.cfg:
  - make sure that libflashsupport gets removed on upgrade
    (LP: #285657)
* DistUpgrade/ReleaseAnnouncement:
  - updated for the release candidate

184. By Michael Vogt on 2008-10-20

* DistUpgrade/xorg_fix_intrepid.py:
  - only update the InputDevices if xserver-xorg-core
    actually is version 2:1.5.0 or higher
  - make section checks case-insensitive (thanks to
    Alberto Milone)
* DistUpgrade/DistUpgrade.glade:
  - remove has_focus default in the conffiel dialog

183. By Michael Vogt on 2008-10-15

* DistUpgrade/DistUpgradeController.py:
  - workaround kde tmpfile permissions (LP: #277431)
* UpdateManager/Common/utils.py:
  - do not crash if gconfd is not availabe/unusable
    (LP: #281248)
* DistUpgrade/DistUpgradeViewKDE.py:
  - do not use "kde" frontend during the upgrade, it
    crashes because of the kde3->kde4 transition
    if run at the wrong time (LP: #283942)
* DistUpgrade/DistUpgradeView.py:
  - ignore SIGPIPE when forking the Dpkg::Pre-Install
    scripts to fix error with etckeeper (LP: #283642)

182. By Michael Vogt on 2008-10-15

[ Jonathan Riddell ]
* DistUpgrade/DistUpgradeQuirks.py:
  - Fix crash from not having gettext imported

[ Michael Vogt ]
* revert the fglrx->ati transition (LP: #247376)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/update-manager
This branch contains Public information 
Everyone can see this information.

Subscribers