lp:ubuntu/intrepid-proposed/openldap

Created by James Westby on 2009-06-27 and last modified on 2009-08-10
Get this branch:
bzr branch lp:ubuntu/intrepid-proposed/openldap
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

11. By Mathias Gug on 2009-03-25

debian/patches/gnutls-enable-v1-ca-certs: Enable V1 CA certs to be
trusted (LP: #305264).

10. By Mathias Gug on 2008-11-04

Don't use local statement in config script as it fails if /bin/sh
points to bash (LP: #286063).

9. By Matthias Klose on 2008-10-24

Disable the testsuite on hppa. Allows building of packages on this
architecture again, once this package is in the archive.
LP: #288908.

8. By Mathias Gug on 2008-10-13

Don't set admin passwords in ldif files if adminpw is empty.
(LP: #273988LP: #276606).

7. By Mathias Gug on 2008-09-24

* debian/slapd.postinst, debian/slapd.script-common: set correct ownership
  and permissions on /var/lib/ldap, /etc/ldap/slapd.d (group readable) and
  /var/run/slapd (world readable). (LP: #257667).
* debian/slapd.script-common:
  - Fix package reconfiguration:
    + Remove slapd.d/ directory if it already exists when creating a new
      configuration.
    + Fix backup directory naming for multiple reconfiguration.

6. By Mathias Gug on 2008-08-26

* debian/patches/nssov-build, debian/rules:
  Build and package the nss overlay.
* debian/schema/misc.ldif: add ldif file for the misc schema, which defines
  rfc822MailMember (required by the nss overlay).

5. By Kees Cook on 2008-08-20

debian/{control,rules}: enable PIE hardening

4. By Mathias Gug on 2008-08-11

* New upstream version:
  - Mainly bug fixes.
  - New nss slapd overlay (not compiled by default).
* Use cn=config as the default configuration backend instead of
  slapd.conf. Migrate slapd.conf file to /etc/ldap/slapd.d/ on upgrade
  asking the end user to enter a new password to control the access to the
  cn=config tree.

3. By Mathias Gug on 2008-07-30

[ Mathias Gug ]
* Merge from debian unstable, remaining changes:
  - debian/apparmor-profile: add AppArmor profile
  - debian/slapd.postinst: Reload AA profile on configuration
  - updated debian/slapd.README.Debian for note on AppArmor
  - debian/control: Recommends apparmor >= 2.1+1075-0ubuntu6
  - debian/control: Conflicts with apparmor-profiles << 2.1+1075-0ubuntu4
    to make sure that if earlier version of apparmour-profiles gets
    installed it won't overwrite our profile.
  - Modify Maintainer value to match the DebianMaintainerField
    speficication.
  - follow ApparmorProfileMigration and force apparmor compalin mode on
    some upgrades (LP: #203529)
  - debian/slapd.dirs: add etc/apparmor.d/force-complain
  - debian/slapd.preinst: create symlink for force-complain on pre-feisty
    upgrades, upgrades where apparmor-profiles profile is unchanged (ie
    non-enforcing) and upgrades where apparmor profile does not exist.
  - debian/slapd.postrm: remove symlink in force-complain/ on purge
  - debian/patches/fix-ucred-libc due to changes how newer glibc handle
    the ucred struct now.
  - debian/patches/fix-unique-overlay-assertion.patch:
    Fix another assertion error in unique overlay (LP: #243337).
    Backport from head.
* Dropped - implemented in Debian:
  - debian/patches/fix-gnutls-key-strength.patch:
    Fix slapd handling of ssf using gnutls. (LP: #244925).
  - debian/control:
    Add time as build dependency: needed by make test.
* debian/control:
  - Build-depend on libltdl7-dev rather then libltdl3-dev.
* debian/patches/autogen.sh:
  - Call libtoolize with the --install option to install config.{guess,sub}
  files.

[ Jamie Strandboge ]
* adjust apparmor profile to allow gssapi (LP: #229252)
* adjust apparmor profile to allow cnconfig (LP: #243525)

2. By Mathias Gug on 2008-07-10

* Merge from debian unstable, remaining changes:
  - debian/apparmor-profile: add AppArmor profile
  - debian/slapd.postinst: Reload AA profile on configuration
  - updated debian/slapd.README.Debian for note on AppArmor
  - debian/control: Recommends apparmor >= 2.1+1075-0ubuntu6
  - debian/control: Conflicts with apparmor-profiles << 2.1+1075-0ubuntu4
    to make sure that if earlier version of apparmour-profiles gets
    installed it won't overwrite our profile.
  - Modify Maintainer value to match the DebianMaintainerField
    speficication.
  - follow ApparmorProfileMigration and force apparmor compalin mode on
    some upgrades (LP: #203529)
  - debian/slapd.dirs: add etc/apparmor.d/force-complain
  - debian/slapd.preinst: create symlink for force-complain on pre-feisty
    upgrades, upgrades where apparmor-profiles profile is unchanged (ie
    non-enforcing) and upgrades where apparmor profile does not exist.
  - debian/slapd.postrm: remove symlink in force-complain/ on purge
  - debian/patches/fix-ucred-libc due to changes how newer glibc handle
    the ucred struct now.
  - debian/patches/fix-unique-overlay-assertion.patch:
    Fix another assertion error in unique overlay (LP: #243337).
    Backport from head.
  - debian/patches/fix-gnutls-key-strength.patch:
    Fix slapd handling of ssf using gnutls. (LP: #244925).
  - debian/control:
    Add time as build dependency: needed by make test.
* Dropped - implemented in Debian:
  - debian/rules:
    Support debuild nocheck option: don't run tests if nocheck is set.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/karmic/openldap
This branch contains Public information 
Everyone can see this information.

Subscribers