lp:ubuntu/intrepid/monodevelop

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/intrepid/monodevelop
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

33. By Mirco Bauer

* debian/control:
  + Removed libxul-dev from build-dependencies, as monodevelop is not using
    it anymore. (Closes: #480797)
  + Build against libmono-nunit2.2-cil instead of libnunit2.2.6-cil.
  + Added mono-2.0-devel to recommends and mono-1.0-devel to suggests, as
    monodevelop invokes resgen(2) and al(2) when needed for *.resx files.
    (Closes: #485797)
  + Updated debhelper build-dependency to >= 7.
  + Updated cli-common-dev build-dependency to >= 0.5.7
    (needed for cli.make)
* debian/patches/link_system_mono-nunit.dpatch:
  + Link against mono-nunit instead of bundled nunit.
* debian/rules:
  + Include /usr/share/cli-common/cli.make
  + Migrated to debhelper v7 minimalistic style.
* debian/compat:
  + Bumped to 7

32. By Martin Pitt

libnunit2.2.6-cil -> libnunit2.4-cil transition.

31. By Salvatore Palma

Add exuberant-ctags as recommended dep (LP: #249030).

30. By Chris Halse Rogers

Rebuild against new libgtksourceview2.0-cil

29. By Stefan Ebner <email address hidden>

* Merge from Debian unstable. (LP: #209012) Remaining Ubuntu changes:
+ debian/control:
  - Build-dep on xulrunner-1.9-dev instead of firefox-dev
  - Depend on xulrunner-1.9 instead of firefox
+ don't do any MOZILLA_HOME/MOZILLA_FIVE_HOME business which isn't needed
  for xulrunner-1.9 using the standalone glue anymore (gecko gil uses
  standalone by default)
  - add debian/patches/use_xulrunner_1.9.dpatch
  - update debian/patches/00list
* Remove build-dep on libxul-dev and the dep on libxul0d
  since we are using xulrunner1.9 instead.

28. By Alexander Sack

* make xulrunner-1.9-dev build dependency instead of firefox-dev
  - update debian/control
* make xulrunner-1.9 depends instead of firefox
  - update debian/control
* don't do any MOZILLA_HOME/MOZILLA_FIVE_HOME business which isn't needed
  for xulrunner-1.9 using the standalone glue anymore (gecko gil uses
  standalone by default)
  - add debian/patches/use_xulrunner_1.9.dpatch
  - update debian/patches/00list

27. By Mario Limonciello

* Merge from debian unstable. (LP: #134197)
  - Build depend on mono-xsp2-base (LP: #123182)
  - Stability (LP: 159946, 157394, 174083, 152457)
* Remaining changes:
  - Adjust build-depends to re-add firefox-dev
  - Adjust depends to re-add firefox.

26. By Emilio Pozuelo Monfort

* Sync with Debian, remaining changes:
  + debian/control:
    - Build depend on firefox-dev, depend on firefox.
    - Adjust Maintainer field.

25. By Sebastian Dröge

* debian/control:
  + Build depend on desktop-file-utils to fix FTBFS.

24. By Sebastian Dröge

* Sync with Debian, remaining changes:
  + debian/control:
    - Build depend on firefox-dev, depend on firefox.
    - Adjust Maintainer field.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/karmic/monodevelop
This branch contains Public information 
Everyone can see this information.

Subscribers