lp:ubuntu/hardy-security/python2.5

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/hardy-security/python2.5
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

52. By Jamie Strandboge

* SECURITY UPDATE: optionally disallow setting sys.path when setting
  sys.argv
  - debian/patches/CVE-2008-5983.dpatch: add new C API function,
    PySys_SetArgvEx
  - CVE-2008-5983
* SECURITY UPDATE: fix integer overflows in audioop module
  - debian/patches/CVE-2010-1634.dpatch: Fix incorrect and UB-inducing
    overflow checks
  - CVE-2010-1634
* SECURITY UPDATE: fix DoS in audioop module
  - debian/patches/CVE-2010-2089.dpatch: ensure that the input string length
    is a multiple of the frame size
  - CVE-2010-2089
* SECURITY UPDATE: Fix CGIHTTPServer information disclosure.
  - debian/patches/CVE-2011-1015.dpatch: Relative paths are now collapsed
    within the url properly before looking in cgi_directories.
  - CVE-2011-1015
* SECURITY UPDATE: update urllib and urllib2 for invalid redirections
  - debian/patches/CVE-2011-1521.dpatch: only process Location headers for
    http, https, and ftp
  - http://bugs.python.org/issue11662
  - CVE-2011-1521
* SECURITY UPDATE: fix XSS in SimpleHTTPServer
  - debian/patches/CVE-2011-4940.dpatch: add a charset parameter to the
    Content-type
  - CVE-2011-4940
* SECURE UPDATE: http://bugs.python.org/issue13512
  - debian/patches/CVE-2011-4944.dpatch: create ~/.pypirc securely
  - CVE-2011-4944
* SECURITY UPDATE: xmlrpc: Fix an endless loop in SimpleXMLRPCServer upon
  malformed POST request
  - debian/patches/CVE-2012-0845.dpatch: break if don't receive EOF in
    Lib/SimpleXMLRPCServer.py
  - CVE-2012-0845
* SECURITY UPDATE: Denial of service via hash collisions
  - debian.patches/CVE-2012-0876+CVE-2012-1148.dpatch: Add random salt value
    to hash inputs in lib/xmlparse.c
  - CVE-2012-0876
* SECURITY UPDATE: Denial of service via memory leak
  - debian.patches/CVE-2012-0876+CVE-2012-1148.dpatch: Properly reallocate
    memory in lib/xmlparse.c
  - CVE-2012-1148
* SECURITY UPDATE: fix DoS in smtpd.py
  - debian/patches/CVE-2010-3493.dpatch: adds proper error handling on
    accept() when smtpd accepts new incoming connections
  - http://bugs.python.org/issue9129
  - CVE-2010-3493

51. By Jamie Strandboge

* SECURITY UPDATE: fix DoS via malformed XML
  - debian/patches/CVE-2009-3720.dpatch: update Modules/expat/xmltok_impl.c
    to not access beyond end of input string
  - CVE-2009-3720
* SECURITY UPDATE: fix DoS via malformed UTF-8 sequences
  - debian/patches/CVE-2009-3560.dpatch: update Modules/expat/xmlparse.c to
    properly recognize the end of a token
  - CVE-2009-3560

50. By Marc Deslauriers

* SECURITY UPDATE: arbitrary code execution via multiple integer
  overflows
  - debian/rules, debian/patches/CVE-2008-4864.dpatch: introduce new
    functions for size checks in Modules/imageop.c, introduce tests in
    Lib/test/test_imageop.py.
  - CVE-2008-4864
* Increment release to -2ubuntu6 to supersede a package that was deleted
  from -proposed. This release does _not_ contain the -2ubuntu5 changes.

49. By Kees Cook

* SECURITY UPDATE: arbitrary code execution via multiple integer overflows.
* debian/rules, debian/patches/CVE-2008-3144.dpatch,
  debian/patches/CVE-2008-3142.dpatch, debian/patches/CVE-2008-2316.dpatch,
  debian/patches/CVE-2008-2315.dpatch: upstream fixes, thanks to
  Robert Buchholz.

48. By Matthias Klose

* Fix CVE-2008-1679, integer overflows in the imageop module.
* Fix CVE-2008-1721, integer signedness error in the zlib extension module.
* Fix issue 2587, PyString_FromStringAndSize() to be considered unsafe.
* Fixes for issues (taken from the 2.5 branch):
  - Issue 2321: Reduce memory usage (increase the memory that is returned
    to the system) by using pymalloc for the data of unicode objects.
  - Issue 2515: _sqlite: Don't crash when trying to fetch data from a
    closed cursor.
  - Issue 2482: Make sure that the coefficient of a Decimal instance
    is stored as a str instance rather than a unicode instance.
    Regression compared to 2.5.1.

47. By Matthias Klose

Fix urllib2 file descriptor happens byte-at-a-time, reverting
a fix for excessively large memory allocations when calling .read()
on a socket object wrapped with makefile(). LP: #214183.

46. By Matthias Klose

* Build depend on libdb4.6-dev on amd64, i386, lpia; use libdb4.2-dev
  for all other architectures.
* Backport new function signal.set_wakeup_fd from the trunk.
  Background: http://bugzilla.gnome.org/show_bug.cgi?id=481569
* Regenerate the documentation.

45. By Matthias Klose

* Merge with Debian; remaining changes:
  - Include the pregenerated documentation.
  - Set priority of python2.5-minimal to required.
  - Build python2.5-doc from the pregenerated documentation.

44. By Matthias Klose

Build-depend on libdb4.2-dev on all architectures; 4.6 is seriously
broken when used with the _bsddb extension. LP: #196147.

43. By Matthias Klose

Move site.py to python2.4-minimal, remove `addbuilddir' from site.py,
which is unnecessary for installed builds.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/python2.5
This branch contains Public information 
Everyone can see this information.

Subscribers