lp:ubuntu/hardy-proposed/pidgin

Created by James Westby on 2009-06-27 and last modified on 2010-02-13
Get this branch:
bzr branch lp:ubuntu/hardy-proposed/pidgin
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

24. By Chris Coulson on 2009-10-30

* debian/patches/86_yahoo_protocol_fix.patch:
  - Backport upstream changes to use version 16 of the Yahoo!
    Messenger Protocol. The old authentication mechanism was
    disabled, meaning that it can no longer be used for signing in
    to Yahoo! services (LP: #389322)

23. By Didier Roche on 2009-03-10

Apply upstream patch to fix connexion issue with new ICQ
protocol: debian/patches/80_fix_ICQ_new_protocol.patch (LP: #340151)

22. By Iain Lane on 2008-07-02

Apply patch from upstream to fix issue where ICQ would not connect
(LP: #244591)

21. By Sebastien Bacher on 2008-04-09

rebuild due to liblaunchpad-integration soname change

20. By Pedro Fragoso on 2008-04-04

* Sync with Debian, remaining Ubuntu changes; (LP: #211769)
  - debian/control:
    + Set Maintainer to Ubuntu Core Developers.
    + Add build-deps on liblaunchpad-integration-dev, intltool,
      libnm-glib-dev (for --enable-nm)
    + Drop build-deps on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1) as
      this library is in universe.
    + Drop the libpurple0 recommends on libpurple-bin.
    + Add a gaim transitionnal package for upgrades.
    + Moved finch's libx11-6 dependency to Suggests
  - Ship compatibility symlinks via debian/gaim.links
  - debian/rules:
    + Pass --enable-nm to configure to enable NetworkManager support
    + Pass --disable-silc to configure to disable silc support even if
      it's installed in the build environment.
    + Add X-Ubuntu-Gettext-Domain to the desktop file and update the
      translation templates in common-install-impl::.
    + Added necessary arguments to dh_shlibdeps for finch
  - Update debian/prefs.xml to set the notify plugin prefs
    /plugins/gtk/X11/notify/* and set /pidgin/plugins/loaded to load
    the notify plugin
  - debian/patches:
    + 02_lpi for LP integration
    + 04_let_crasher_for_apport to stop catching the SIGSEGV signal
      and let apport handle it
    + 05_default_to_irc_ubuntu_com to set the default IRC
      server to irc.ubuntu.com.
    + 70_autoconf patch

19. By Adrien Cunin on 2008-03-29

* Moved finch's libx11-6 dependency to Suggests: (LP: #195718)
   - debian/rules: added necessary arguments to dh_shlibdeps
   - debian/control: added Suggests: ${shlibs:Suggests}

18. By Pedro Fragoso on 2008-03-11

* Sync with Debian, remaining Ubuntu changes; (LP: #201055)
  - Set Maintainer to Ubuntu Core Developers.
  - Add build-deps on liblaunchpad-integration-dev, intltool,
    libnm-glib-dev (for --enable-nm) (Ubuntu #112720).
  - Drop build-deps on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1) as
    this library is in universe.
  - Drop the libpurple0 recommends on libpurple-bin.
  - Add a gaim transitionnal package for upgrades.
  - Ship compatibility symlinks via debian/gaim.links.
  - Pass --enable-nm to configure to enable NetworkManager support.
  - Pass --disable-silc to configure to disable silc support even if
    it's installed in the build environment.
  - Add X-Ubuntu-Gettext-Domain to the desktop file and update the
    translation templates in common-install-impl::.
  - Update debian/prefs.xml to set the notify plugin prefs
  - Update debian/prefs.xml to set the notify plugin prefs
    /plugins/gtk/X11/notify/* and set /pidgin/plugins/loaded to load
    the notify plugin
  - Add LPI integration patch, 02_lpi.
  - Add patch 04_let_crasher_for_apport to stop catching the SIGSEGV signal
    and let apport handle it.
  - Add patch 05_default_to_irc_ubuntu_com to set the default IRC
    server to irc.ubuntu.com.
  - Add autoconf patch, 70_autoconf.

17. By Pedro Fragoso on 2007-12-21

* Sync with Debian, remaining Ubuntu changes; (LP: #177811)
  - Set Maintainer to Ubuntu Core Developers.
  - Add build-deps on liblaunchpad-integration-dev, intltool,
    libnm-glib-dev (for --enable-nm) (Ubuntu #112720).
  - Drop build-deps on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1) as
    this library is in universe.
  - Drop the libpurple0 recommends on libpurple-bin.
  - Add a gaim transitionnal package for upgrades.
  - Ship compatibility symlinks via debian/gaim.links.
  - Pass --enable-nm to configure to enable NetworkManager support.
  - Pass --disable-silc to configure to disable silc support even if
    it's installed in the build environment.
  - Add X-Ubuntu-Gettext-Domain to the desktop file and update the
    translation templates in common-install-impl::.
   - Update debian/prefs.xml to set the notify plugin prefs
    /plugins/gtk/X11/notify/* and set /pidgin/plugins/loaded to load
    the notify plugin; Ubuntu: #13389.
  - Add LPI integration patch, 02_lpi.
  - Add patch 04_let_crasher_for_apport to stop catching the SIGSEGV signal
    and let apport handle it.
  - Add patch 05_default_to_irc_ubuntu_com to set the default IRC
    server to irc.ubuntu.com.
  - Add autoconf patch, 70_autoconf.

16. By Loïc Minier on 2007-11-06

* Sync with Debian; remaining Ubuntu changes:
  - Set Maintainer to Ubuntu Core Developers.
  - Add build-deps on liblaunchpad-integration-dev, intltool,
    libnm-glib-dev (for --enable-nm), libsqlite3-dev (Ubuntu #112720).
  - Drop build-deps on libsilc-1.1-2-dev | libsilc-dev (>= 1.1.1) as this
    library is in universe.
  - Change transition version from 2.1.1-2 to 1:2.1.1-2 in
    pidgin-dev.preinst, pidgin.preinst, and pidgin-dbg.preinst.
  - Change pidgin's conflicts and replaces against pidgin-data from 2.1.1-2
    to 1:2.1.1-2.
  - Let pidgin-data replace gaim-data (<< 1:2.0.0+beta6-3).
  - Change finch, libpurple-bin, and libpurple0 conflicts and replaces
    against pidgin from 2.1.1-2 to 1:2.1.1-2.
  - Change libpurple-dev and finch-dev conflicts and replaces against
    pidgin-dev from 2.1.1-2 to 1:2.1.1-2.
  - Drop the libpurple0 recommends on libpurple-bin.
  - Add a gaim transitionnal package for upgrades.
  - Ship compatibility symlinks via debian/gaim.links.
  - Pass --enable-nm to configure to enable NetworkManager support.
  - Pass --disable-silc to configure to disable silc support even if it's
    installed in the build environment.
  - Don't remove the debian/copyright file on clean and generate one
    by manually running the sed snippet from common-install-impl::.
  - Add X-Ubuntu-Gettext-Domain to the desktop file and update the
    translation templates in common-install-impl::.
  - Drop debian/patches/14_xulrunner_nss.patch as libnss / libnspr are
    properly detected by the upstream configure already.
  - Update debian/prefs.xml to set the notify plugin prefs
    /plugins/gtk/X11/notify/* and set /pidgin/plugins/loaded to load the
    notify plugin; Ubuntu: #13389.
  - Add LPI integration patch, 02_lpi.
  - Add patch 04_let_crasher_for_apport to stop catching the SIGSEGV signal
    and let apport handle it.
  - Add patch 05_default_to_irc_ubuntu_com to set the default IRC server to
    irc.ubuntu.com.
  - Add autoconf patch, 70_autoconf.

15. By Sebastien Bacher on 2007-10-10

* debian/patches/80_from_upstream_fix_irc_formatting_issue.patch:
  - patch from upstream, fix an IRC formatting issue
    (LP: #141201)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/karmic/pidgin
This branch contains Public information 
Everyone can see this information.

Subscribers