lp:ubuntu/hardy-updates/libnss-db

Created by James Westby on 2010-03-31 and last modified on 2010-03-31
Get this branch:
bzr branch lp:ubuntu/hardy-updates/libnss-db
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

10. By Kees Cook on 2010-03-30

* SECURITY UPDATE: allows reading of arbitrary file contents (LP: #531976)
  - Add 200-set-db-environment.dpatch: set environment correctly.
  - CVE-2010-0826

9. By Timo Aaltonen on 2008-01-18

* Merge from debian unstable, remaining changes:
  - Use debhelper instead of yada. Drop perl, libipc-run-perl Build-deps.
  - Use dpatch instead of simple-patchsys.
  - Add 120-no-po.patch to not build the po directory.
  - Change the Maintainer address.
* Modified patch 120 not to patch Makefile.in, not necessary and breaks
  clean target.
* Remove db-compat-copy-makedb.c on clean.

8. By Martin Pitt on 2008-01-03

debian/control, debian/patches/020-db4.patch: Switch to db4.6.

7. By Steve Kowalik on 2007-09-19

Remove spurious intltoolize from debian/rules.

6. By Steve Kowalik on 2007-09-19

* Accidently convert package to using debhelper, since a few people have
  a vendetta against yada.
* Convert the simple patches to dpatch.
* Remove perl and libipc-run-perl from the Build-Depends.
* Change the Build-Depends and 020-db4.patch to use db4.5 instead of 4.3.
* Add 120-no-po.patch to not build the po directory.
* Modify Maintainer field as per spec.

5. By Matthias Klose on 2007-07-31

debian/rules: explicitely use bash for the install.

4. By Piotr Roszatycki <dexter@nigella> on 2005-12-19

* Renumbered Debian patches.
* Modified 060-errno.patch:
  - Do not remove errnop variable. It causes fatal error on amd64. Just
    set errno to ENOENT by default. Closes: #341773.
* Modified 070-selinux.patch:
  - Fix configure script for SELinux and fix FTBFS on hurd-i386.
    Closes: #322190.
* Removed 120-gettextize.patch:
  - Call gettextize in build time with a little help of IPC::Run.

3. By Piotr Roszatycki on 2005-05-23

* NMU
* debian/local/db-Makefile:
  - Set correct umask before creating files. Closes: #284859.
* debian/packages.d/libnss-db.in: %postinst%:
  - Don't remove *.db files on upgrade. It can break the system if the files
    are not generated locally. Closes: #309492.
  - Use `invoke-rc.d nscd restart'.
* debian/rules:
  - The symlink in /usr/lib should be absolute.

2. By Ben Collins on 2002-04-12

Rebuild with newer libdb3

1. By Ben Collins on 2002-04-12

Import upstream version 2.2

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/libnss-db
This branch contains Public information 
Everyone can see this information.

Subscribers