Ubuntu

lp:ubuntu/hardy-proposed/compiz

Created by James Westby on 2011-04-08 and last modified on 2011-04-08
Get this branch:
bzr branch lp:ubuntu/hardy-proposed/compiz
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Mature

Recent revisions

102. By Michael Vogt on 2008-05-28

* debian/patches/028_compiz_manager_blacklist:
  - blacklist i815 (LP: #221920)
* debian/patches/030_fix_screensaver:
  - dropped, the xserver is fixed now so we do not need
    to work around it (LP: #160264)
  - this means, that this version can *not* be backported
    to gutsy (or any older version of ubuntu) unless the
    xserver there is patched too

101. By Michael Vogt on 2008-04-15

[ Travis Watkins ]
* debian/patches/038_from_git_fix_incomplete_rotate.patch:
  - cherry pick git commit cd93bb966ccf0bd951d202ec0cf4df610af0c9e0
    to fix incomplete rotation in rotate plugin (LP: #216786)

100. By Michael Vogt on 2008-04-14

* debian/patches/043-blur-plugin-fix-from-git.patch:
  - cherry pick git commit bb8317d6e18a1c2da587f3313fadae42715e04a1
    to fix buffer overflows with gaussian shader radius bigger
    than 12.

99. By Michael Vogt on 2008-04-11

[ Travis Watkins ]
* debian/patches/037_fullscreen_stacking_fixes.patch:
  - check for valid window (LP: #206866)

98. By Michael Vogt on 2008-04-10

[ Travis Watkins ]
* debian/patches/037_fullscreen_stacking_fixes.patch:
  - check for valid window (LP: #206866)

97. By Michael Vogt on 2008-03-11

[ Travis Watkins ]
* debian/patches/036_blacklist_ati_on_laptop.patch:
  - don't start compiz if using the ati or radeon driver
    and using a laptop as mobility cards have issues (LP: #197135)
* debian/patches/037_fullscreen_stacking_fixes.patch:
  - keep window on top of fullscreen windows during move
  - when changing from fullscreen to non-fullscreen keep
    window on top of other fullscreen windows (LP: #173303)

[ Michael Vogt ]
* debian/patches/040_resolve-animation-fade-conflict_from_upstream.patch:
  - patch from Erkin Bahceci to resolve conflict between fade and
    animation plugin (thanks!)
* debian/compiz-decorator:
  - added compiz-decorator script (thanks to Jigish Gohil)
* debian/patches/029_compiz_manager_decoration.patch:
  - remove starting of the decorator from compiz-manager, this
    is the job of the decorator plugin now
* debian/patches/029_compiz_manager_nvidia_settings.patch:
  - check for nvidia-settings before using it (thanks to
    Daniel Halhler, LP: #199944)
* debian/patches/029_default_options:
  - use compiz-decorator as default decorator command
* debian/patches/032_compiz_manager_default_window_manager.patch:
  - updated (conflicted with 029_compiz_manager_decoration)
* debian/rules:
  - install compiz-decorator
* debian/patches/041-start-decorator.patch:
  - cherry pick git commit 8cde7903f to start decorator early

96. By Michael Vogt on 2008-03-07

* new upstream release:
  - fix crash in window decorators (LP: #128651)
  - fix crash in cairo_set_line_width (LP: #149535)
  - fixes in compiz scale (LP: #159780)
  - fix resizing taskbar (LP: #172716)
  - do not rotate to non-existing faces (LP: #149460)
  - fixed incorrect switcher position (LP: #158877)
  - add missing i18n (LP: #152911)
  - do not switch viewports when a window requests to
    get focus but wait if it actually really got it
  - and more fixes
* debian/control:
  - update standards version
  - use ${binary:Version}
  - add section 'libdevel' to libdecoration0-dev
  - updated depends for the compiz metapackage
* debian/copyright:
  - update FSF adress

95. By Michael Vogt on 2008-03-03

update build-dependencies to gnome-control-center-dev
to make it build again

94. By Michael Vogt on 2008-02-29

* new git snapshot
* ABI break
* add proper breaks for plugins-{main,extra}, libcompizconfig0
* enable 'session' plugin
* debian/patches/022_fix_session_managment.patch:
  - updated to the current code

93. By Michael Vogt on 2008-02-25

add libxml2-dev and libxslt1-dev to the depends of
compiz-dev (thanks to Michael Bienia)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/compiz
This branch contains Public information 
Everyone can see this information.

Subscribers