lp:ubuntu/gutsy-security/lasso

Created by James Westby on 2009-07-19 and last modified on 2009-07-19
Get this branch:
bzr branch lp:ubuntu/gutsy-security/lasso
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

11. By Stefan Lesicnik on 2009-01-14

* SECURITY UPDATE: lasso does not properly check the return value from the
  OpenSSL DSA_verify function (LP: #317181).
  - lasso/xml/tools.c: Correctly check for signature validity.
  - CVE-2009-0050

10. By Michael Bienia on 2007-07-31

* Merge from debian unstable. Remaining changes:
  + debian/control:
    - Modify Maintainer value to match DebianMaintainerField spec.
* debian/rules:
  + Add CC=gcc-4.2 to the configure call else configure won't find jni.h
    from libgcj8-dev.
* configure{,.ac}:
  + Add missing quotes around the value for PHP[45]_LIBS.

9. By Michael Bienia on 2007-03-13

* Don't build a php4 module anymore.
* debian/control: Rename Original-Maintainer to XSBC-Original-Maintainer.

8. By Stephan Ruegamer on 2007-03-06

* Rebuild because of PHP4 API change
* debian/rules:
  - changed php-config to php-config4
* debian/control:
  - Added Ubuntu MOTU Maintainer field
  - Moved old Maintainer field to Original-Maintainer

7. By Frederic Peters <email address hidden> on 2006-10-21

* Converted to new Python policy (merged from unreported Ubuntu patch)
  * debian/control: keep conflict on python2.4-lasso which is unnecessary
    for Debian but will reduce Ubuntu changes.

6. By Matthias Klose on 2006-09-08

Rebuild to add support for python2.5.

5. By Matthias Klose on 2006-07-11

* Synchronize with Debian unstable.
* Convert to updated Python policy.

4. By Loic Pefferkorn <email address hidden> on 2005-11-25

Resynchronise with Debian.

3. By Stephan Ruegamer on 2005-09-16

* debian/control: removed hardcoded php dependency, added php:Depends
  substvar
* debian/rules: added phpapiver, added substitution of php:Depends

2. By Frederic Peters <email address hidden> on 2004-09-13

debian/control: added libexpat1-dev to build-depends; it is required for
the PHP binding.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/karmic/lasso
This branch contains Public information 
Everyone can see this information.

Subscribers