lp:debian/upower

Created by James Westby on 2010-02-23 and last modified on 2015-06-21
Get this branch:
bzr branch lp:debian/upower
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

59. By Martin Pitt on 2015-05-29

* New upstream release:
  - Support Logitech Unifying in Linux 3.19+ (Closes: #785725, LP: #1448834)
  - Fix Bluetooth HID batteries with recent kernels (Closes: #772095,
    LP: #772095)
* Drop git_init_variants.patch, included in this release.

58. By Martin Pitt on 2015-04-27

* Update Vcs-* fields for anonscm.d.o.
* debian/control: Drop obsolete XS-Testsuite: field, dpkg adds this
  automatically now.

57. By Mike Gabriel on 2015-04-06

[ Mike Gabriel ]
* Non-maintainer upload.

[ Vlad Orlov ]
* null-init-pointers.patch: new patch. Properly initialize two
  pointers, avoid segfaults. (Closes: #774546).

56. By Michael Banck on 2014-11-28

* Non-maintainer upload.
* debian/patches/git-fix-memleak.patch
  - Memleak fix. Taken from upstream git head, commit 4221835f (Closes:
    #766762).

55. By Martin Pitt on 2014-09-02

* debian/tests/build: Drop up_client_get_can_suspend() call, this got
  dropped in this upstream version.
* Add upstream patch to fix test suite crash if there is no session bus.
* Add upstream patch to fix test suite for Python 3.4.
* Add upstream patch to split test suite into smaller independent tests.
* Add missing umockdev test dependencies so that the upstream test suite
  actually runs.

54. By Michael Biebl on 2014-08-26

Upload to unstable.

53. By Andreas Henriksson on 2014-07-12

* Team upload.
* Bump Standards-Version to 3.9.5
* Upload to unstable.

52. By Martin Pitt on 2013-10-23

* Drop hardcoded binary glib dependency, it's already being generated
  automatically from the versioned build depends.
* Add 00git_clamp_percentage.patch: Clamp percentage for overfull batteries,
  to avoid showing 0% on some fully charged battery models. Fixes regression
  from 0.9.22. (LP: #1240673)

51. By Martin Pitt on 2013-10-20

* New upstream bug fix release.
* Force libglib2.0-0 to be at least 2.36 to avoid running against earlier
  glib versions which still required g_type_init(). (Closes: #722612)

50. By Martin Pitt on 2013-10-08

* New upstream release.
* Drop 00git_updates.patch, included in new release.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers