lp:debian/adonthell

Created by James Westby and last modified
Get this branch:
bzr branch lp:debian/adonthell
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

14. By Barry deFreese

Remove extra flag from --with python2. (Closes: #710317).

13. By Barry deFreese

* Acknowledge NMU.
* Clean up packaging.
  - Change debian/rules to dh7 style.
  - Bump debhelper and compat to 7.
  - Replace Conflicts with Breaks in control.
  - Add hardening flags.
  - Update Homepage to new address.
  - Remove links against libdl and libutil since they aren't used.
* Bump Standards Version to 3.9.4.

12. By Luca Falavigna

* Non-maintainer upload.
* debian/patches/12_no_sparc_bytecompile.patch:
  - Do not bytecompile Python files during build on sparc, workaround
    to let adonthell compile again. Generated files were not installed
    in the package, and byte-compilation is performed at a later stage
    by python-support anyway (Closes: #639450).

11. By Evgeni Golov

* Team upload.
* Thanks Torsten for the NMU!
* Fix FTBFS caused by the NMU.
  configure looks for a "swig" binary, the swig2.0 package provides
  just swig2.0, making the build fail. Build-Depend on swig (>= 1.3),
  which will pull in the latest stable swig by default.
  Closes: #633107, #630933, #632531

10. By Torsten Landschoff

* Non-maintainer upload.
* Build with swig2.0 to allow removal of the obsolete swig1.3 package.

9. By Evgeni Golov

* Team upload.

[ Iain Lane ]
* debian/control: Remove myself from Uploaders

[ Peter De Wachter ]
* Fixed FTBFS with newer gcc. (Closes: #624998) (LP: #765984)
  - Added patch: 11_ftbfs_with_gcc-4.6.diff

[ Evgeni Golov ]
* Drop the "A" from the Description.
* Add ${misc:Depends} to Depends.

8. By Moritz Muehlenhoff <email address hidden>

Drop support for armel for now (Closes: #562904)

7. By Moritz Muehlenhoff <email address hidden>

* Add myself to uploaders
* Drop special case handling of Python for arm, Python 2.4 is being
  removed. If it still fails with the current toolchain, we need to
  find a fix in Python or drop support for Arm (Closes: #562401)
* Drop versioned Build-Depends for python-dev, swig1.3 and
  python-support; all satified even in Etch
* Convert to source format 3 (quilt)

6. By Barry deFreese

[ Barry deFreese ]
* 10_ftbfs_with_gcc-4.4.diff. Fix FTBFS with gcc-4.4. (Closes: #546356).
  + Thanks to Ilya Barygin for the patch!
* Add README.source for quilt.
* Bump Standards Version to 3.8.3. (No changes needed).

5. By Barry deFreese

[ Barry deFreese ]
* Update my e-mail address.
* Bump Standards Version to 3.8.2. (No changes needed).

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:debian/squeeze/adonthell
This branch contains Public information 
Everyone can see this information.

Subscribers