lp:debian/jessie/spice

Created by Ubuntu Package Importer on 2013-05-06 and last modified on 2014-05-23
Get this branch:
bzr branch lp:debian/jessie/spice
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

12. By Michael Tokarev <email address hidden> on 2014-05-23

* new upstream release. Can now build without celt!
* Dropped patches:
  - make-celt-to-be-optional.patch
  - link-server-test-with-libm-libpthread.patch
  - enable_subdir-objects.patch
  - fix-buffer-overflow-when-decrypting-client-spice-ticket.patch
* build-depend on libopus-dev, which enables opus support
  (no --enable-opus configure flag for now)
* do not remove .version in clean anymore (it is part of the tarball)
* do not use dh_autoreconf, since we aren't changing autoconf anymore
* update libspice-server1.symbols with new symbols
* introduce libspice-server1-dbg package (Closes: #743850)
* fix the vcs-browse url (Closes: #722241)

11. By Liang Guo <email address hidden> on 2013-11-07

Fix CVE-2013-4282 (Closes: #728314)

10. By Hideki Yamane on 2013-10-21

* Non-maintainer upload.
* debian/patches
  - add enable_subdir-objects.patch (Closes: #724093)

9. By Liang Guo <email address hidden> on 2013-07-25

* New upstream release (Closes: #717030)
* Remove .version after build (Closes: #671627)
* debian/control:
  - Bump Standards-Version to 3.9.4 (no changes)
  - Update VCS-* to use canonical URIs
* debian/patches:
  - fix-tests-warnings.patch, refresh
  - link-server-test-with-libm-libpthread.patch, add (Closes: #713681)
* Refresh libspice-server1.symbols

8. By Liang Guo <email address hidden> on 2013-05-19

* New upstream release
* debian/patches:
  - fix-build-warning-PIXEL.patch, remove, applied upstream
  - link-libspice-server-with-libm-libpthread.patch, remove,
    applied upstream
  - spice-common-remove-version-construction.patch, remove,
    applied upstream
  - fix-tests-warnings.patch, refresh
  - make-celt-to-be-optional.patch, refresh
* libspice-server-dev should depends on libglib2.0-dev, or
  qxl driver compile will fail.
* Refresh libspice-server1.symbols

7. By Liang Guo <email address hidden> on 2012-06-09

* New upstream release
* Breaks spice-gtk (<= 0.12-2)
* Refresh debian/libspice-server1.symbols
* debian/control:
  - Update my e-mail address
  - Add python-pyparsing to Build-Depends
* debian/patches:
  - Remove fix-error-path-return-in-snd_set_record_peer.patch,
    applied upstream
  - Refresh make-celt-to-be-optional.patch
  - Refresh link-libspice-server-with-libm-libpthread.patch
* Simplify debian/rules, celt removed, no reason to use
  traditional one
* Disable smartcard, not in debian yet
* Refresh debian/copyright

6. By Michael Tokarev <email address hidden> on 2012-02-01

added dependency on libxinerama-dev to
libspice-server-dev, temporarily, till
either upstream or we will have better
solution. libspice-server does not use
xinerama in any way, yet it is listed in
the requiriments in the pkg-config file,
which is generated at configure time.
(Closes: #658173)

5. By Liang Guo on 2011-11-29

[ Liang Guo ]
* New upstream release (Closes: #651262)
* Refresh debian/copyright
* Remove fix-typo-in-cmd_line_parser-cpp.patch, applied upstream
* Remove fix-typo-in-record-cpp.patch, applied upstream
* Remove use-requires-private-for-libspice-pkgconfig.patch, applied upstream
* Change Build-Depends on libspice-protocol-dev to (>= 0.9.1~)
* Refresh libspice-server1.symbols
* Update debian/rules clean target
* Ignore common/win/my_getopt-1.5/Makefile change when building package
* debian/control: set DMUA

[ Michael Tokarev ]
* use `rm -f' instead of `-rm' in debian/rules clean targets
* remove python_modules/*.pyc in clean target

4. By Liang Guo on 2011-10-20

* New upstream release
* Update debian/copyright to fit DEP-5
* Remove drop-unnecessary-build-request.patch, applied upstream
* Update Build-Depends on libspice-protocol-dev to 0.8.2~
* Disable GUI support, CEGUI version in Debian not supported
* Add libjpeg-dev to Build-Depends
* Refresh libspice-server1.symbols

3. By Liang Guo on 2011-08-16

[ Michael Tokarev ]
* move libraries used internally by libspice-server from Requires
  to Requires.private in pkg-config file

[ Liang Guo ]
* Add libpixman-1-dev and libssl-dev to libspice-server-dev
  Depends (Closes: #637189)
* Remove alsa, xrandr, xfixes, x11, xext and xrender
  from spice-server.pc Requires
* Fix typo in debian/spicec.1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:debian/spice
This branch contains Public information 
Everyone can see this information.

Subscribers