lp:debian/experimental/upower

Created by James Westby on 2010-02-21 and last modified on 2015-03-13
Get this branch:
bzr branch lp:debian/experimental/upower
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

26. By Martin Pitt on 2015-03-13

libupower: Fix crash due to uninitialized GVariant. (Closes: #774546,
LP: #1428337)

25. By Martin Pitt on 2014-12-18

* New upstream bug fix release:
  - Fix memory leaks with Logitech receivers. (LP: #757551)
  - Drop all debian/patches/*, included upstream.
* Bump Standards-Version to 3.9.6 (no changes necessary).

24. By Martin Pitt on 2014-07-16

[ Martin Pitt ]
* Drop pm-utils | systemd dependency, now unnecessary as suspend/hibernate
  functionality was dropped.

[ Michael Biebl ]
* New upstream release.
* Drop Build-Depends on libpolkit-gobject-1-dev, no longer necessary.
* Rename libupower-glib2 → libupower-glib3 for the soname bump.
* Update symbols file, remove the *_is_docked symbols.
* Upload to experimental.

23. By Sjoerd Simons on 2014-04-26

debian/control: Let libupower-glib2 recommend upower

22. By Andreas Henriksson on 2014-02-16

* Team upload.
* Imported Upstream version 0.99.0
* Rename package for new SONAME (1->2)
* Update symbols
* Drop debian/patches/00git_clamp_percentage.patch, merged upstream.
* Drop debian/patches/no_deprecation_define.patch
  - deprecated features no longer exists at all.
* Drop debian/patches/always_use_pm-utils_backend.patch
  - new upstream now requires logind support
* upower no longer install polkit files

21. By Martin Pitt on 2013-03-19

* New upstream release.
* Bump libpolkit-gobject-1-dev build dependency as per upstream
  configure.ac.
* Build with --enable-deprecated, we are not ready yet to drop
  suspend/hibernate functionality.
* Bump Standards-Version to 3.9.4. No changes necessary.
* Add "build" autopkgtest to compile/link/run a simple program against
  libupower-glib.
* Drop unnecessary "needs-root" restriction from upstream-system
  autopkgtest.
* Add no_deprecation_define.patch: Do not require applications to define
  UPOWER_ENABLE_DEPRECATED to access suspend/resume functionality. We are
  not ready to do that yet in Debian.

20. By Martin Pitt on 2013-01-03

New upstream release.

19. By Michael Biebl on 2011-03-21

* New upstream release.
  - Fix bitmap check in the input code. (Closes: #616474)
  - Add an option for polling dock devices in UPower.conf, defaulting to
    false. (Closes: #613745)
* debian/control
  - Bump Build-Depend on libgudev-1.0-dev to (>= 147).
* debian/libupower-glib1.symbols
  - Add new up_client_get_lid_force_sleep symbol.

18. By Michael Biebl on 2011-02-23

[ Frédéric Péters ]
* Enable gobject introspection support. (Closes: #614795)
  - Add Build-Depends on libgirepository1.0-dev (>= 0.9.12),
    gobject-introspection (>= 0.9.12-4~) and gir1.2-glib-2.0.
  - Add package gir1.2-upowerglib-1.0 containing the typelib file.
  - Install gir file in libupower-glib-dev.install.
  - Call dh_girepository for libupower-glib1 in debian/rules.

[ Michael Biebl ]
* Bump debhelper compatibility level to 8 and update build dependency on
  debhelper accordingly.

17. By Martin Pitt on 2011-01-07

* New upstream release. Changes since our previous git snapshot:
  - Add an "IsDocked" property.
  - Testsuite: Reduce race condition in history purging check.
  - Update the list of HID UPS devices
  - Fix links to git repository in HACKING
  - Support the power_now sysfs attribute to get time remaining on new
    kernels
* debian/libupower-glib1.symbols: Add new symbol.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers