lp:debian/experimental/spice

Created by Ubuntu Package Importer on 2012-06-03 and last modified on 2013-02-11
Get this branch:
bzr branch lp:debian/experimental/spice
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

10. By Michael Tokarev <email address hidden> on 2013-02-11

* added two patches from Serge Hallyn to fix numerous compiler warnings:
   fix-build-warning-PIXEL.patch
   fix-tests-warnings.patch
* spice-common-remove-version-construction.patch - to stop spice-common
  from produce a ton of `build-aux/git-version-gen: not found' errors
  during autoreconf.

9. By Michael Tokarev <email address hidden> on 2013-01-17

* New upstream release
* debian/patches:
   - Refresh link-libspice-server-with-libm-libpthread.patch
* Refresh debian/cpyright, new files added
* Build client, upstream don't build client by default
* Refresh libspice-server1.symbols
* Add libglib2.0-dev to Build-Depends

[ Michael Tokarev ]
* refresh make-celt-to-be-optional.patch (minor context diff)
* do not build-depend on libspice-protocol-dev
  (upstream always uses included copy)
* add (versioned) dependency on libspice-protocol-dev to libspice-server-dev
  package, since when the latter is installed, embedded protocol headers
  are not installed
* do not build-depend on mesa libs (OpenGL is not enabled by default
  and is not recommended by upstream)
* do not build-depend on libogg-dev
* configure with --disable-silent-rules, so that the compiler command
  line is visible (this fixes the lintian warnings about hardening flags)

8. By Michael Tokarev <email address hidden> on 2012-06-02

* Applying for co-maintenance, adding myself to Uploaders (Closes: #671627)
* Bump Standards-Version to 3.9.3 (no changes)
* link-libspice-server-with-libm-libpthread.patch - missing libraries
* Enable multiarch for libspice-server, bump debhelper compat to 9
* do not require root in clean target
* build-depend on dh-autoreconf and python to be able to run autoreconf
  and python code generator
* use dh_autoreconf, do not ship debian/source/options anymore
* consolidate clean target in debian/rules
* 2 patches:
  - fix-error-path-return-in-snd_set_record_peer.patch (from upstream git),
    which is a pre-requisite for the next patch, and
  - make-celt-to-be-optional.patch (sent to upstream).
  This makes it possible to build spice without celt.
* Disable celt051 usage.

7. By Michael Tokarev <email address hidden> on 2012-02-01

added dependency on libxinerama-dev to
libspice-server-dev, temporarily, till
either upstream or we will have better
solution. libspice-server does not use
xinerama in any way, yet it is listed in
the requiriments in the pkg-config file,
which is generated at configure time.
(Closes: #658173)

6. By Liang Guo on 2012-01-27

* New upstream release
* Refresh libspice-server1.symbols

5. By Liang Guo on 2011-11-29

[ Liang Guo ]
* New upstream release (Closes: #651262)
* Refresh debian/copyright
* Remove fix-typo-in-cmd_line_parser-cpp.patch, applied upstream
* Remove fix-typo-in-record-cpp.patch, applied upstream
* Remove use-requires-private-for-libspice-pkgconfig.patch, applied upstream
* Change Build-Depends on libspice-protocol-dev to (>= 0.9.1~)
* Refresh libspice-server1.symbols
* Update debian/rules clean target
* Ignore common/win/my_getopt-1.5/Makefile change when building package
* debian/control: set DMUA

[ Michael Tokarev ]
* use `rm -f' instead of `-rm' in debian/rules clean targets
* remove python_modules/*.pyc in clean target

4. By Liang Guo on 2011-10-20

* New upstream release
* Update debian/copyright to fit DEP-5
* Remove drop-unnecessary-build-request.patch, applied upstream
* Update Build-Depends on libspice-protocol-dev to 0.8.2~
* Disable GUI support, CEGUI version in Debian not supported
* Add libjpeg-dev to Build-Depends
* Refresh libspice-server1.symbols

3. By Liang Guo on 2011-08-16

[ Michael Tokarev ]
* move libraries used internally by libspice-server from Requires
  to Requires.private in pkg-config file

[ Liang Guo ]
* Add libpixman-1-dev and libssl-dev to libspice-server-dev
  Depends (Closes: #637189)
* Remove alsa, xrandr, xfixes, x11, xext and xrender
  from spice-server.pc Requires
* Fix typo in debian/spicec.1

2. By Liang Guo on 2011-07-23

Initial release (Closes: #560721)

1. By Liang Guo on 2011-07-23

Import upstream version 0.8.2

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:debian/spice
This branch contains Public information 
Everyone can see this information.

Subscribers