lp:debian/experimental/smokeping

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:debian/experimental/smokeping
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

9. By anarcat

* New upstream release to properly fix CVE-2012-0790 (Closes: #659899)
* Acknowledge the NMU, thanks gregor!

8. By anarcat

* new upstream release (Closes: #485977).
* take over maintainership, leaving previous maintainer as uploader
  (Closes: #568742).
* remove patches:
  * 15_clean_makefile.dpatch - makefile is now clean
  * 20_html-parser.dpatch - obsolete
* strip down patch:
  * 10_path_changes.dpatch - only fix the HTML paths
* add patches:
  * fcgi_destdir - setup the fcgi script properly
  * fix-conf-path-cgi - hardcode the path to the config in the CGI script
  * fix-conf-paths - fix paths in main config
  * fix-perl-lib - fix path to PERLIB
  * proper-sample-conf - have a proper sample config
* rewrite debian/rules with debhelper 7
* remove our custom config.d files, instead we split the upstream config
  in multiple files during the build, our modifications are now patches
  to the default config
* remove old (pre 2.3.6) compatibility code, now that even oldstable is
  running that release
* switch to 3.0 (quilt) format

7. By Niko Tyni

debian/patches/20_html-parser.dpatch: fix an incompatibility with
recent versions of HTML::Parser. (Closes: #560562)

6. By Niko Tyni

* Depend on libconfig-grammar-perl instead of bundling it. (Closes: #531196)
* Install the perl code in /usr/share/smokeping/lib instead of
  /usr/share/perl5/smokeping.
* Downgrade the exim4 | mail-transport agent dependency to a suggestion.
  (Closes: #520350)
* Remove the obsolete libnet-perl dependency.
* Depend on javascript libraries instead of bundling them. (Closes: #475285)
  + cpio not used anymore. (Closes: #537026)
* Move away from /var/www but add compatibility symlinks on upgrades.
  See NEWS.Debian. (Closes: #521333)
  + automatically enable the web server configuration on new installations
    where possible.
* Serve UTF-8 by default. Thanks to Elmar Hoffmann. (Closes: #506978)
* Don't ship /var/run/smokeping, it will be created at run time.
* Upgrade to Standards-Version 3.8.2.
  + add Homepage, Vcs-Git, and Vcs-Browser information to debian/control.
* Change the alternate web server recommendation to httpd-cgi as per policy.

5. By Niko Tyni

* Unset LC_ALL in the init script because the daemon needs to
  reset LC_NUMERIC. (Closes: #489766)
* Fix a bashism in the postinst script. Thanks, lintian.

4. By Niko Tyni

* debian/patches/15_clean_makefile.dpatch:
  + remove unneeded and potentially unsecure include paths.
* debian/patches: selected patches from the upstream SVN repository
  + 40_password.dpatch: skip reading the password file when running as a CGI.
  + 50_ldap.dpatch: Make the 'scope' option in the LDAP probe actually work.
  + 60_fping.dpatch:
    * Support the '-S' (set source address, see #198486) fping option.
    * Don't try to execute fping when running as a CGI.
  + 70_syslog.dpatch: Don't die silently if syslogd is unavailable.
    (Closes: #395056)
* Remove all the autogenerated documentation at clean time, to properly
  undo the effects of the 'build' target.
* Install example configuration files for documentation.

3. By Jose Carlos Garcia Sogo

* Include missing matchers methods in binary package (Closes: #295354)
* Add missing suggests: libnet-dns-perl, ssh, libio-socket-ssl-perl,
  libnet-telnet-perl (Closes: #295372)

2. By Jose Carlos Garcia Sogo

Changed /usr/bin/perl for /usr/bin/speedy in the smokeping binary and the
smokeping cgi. (Closes: #140384)

1. By Jose Carlos Garcia Sogo

Import upstream version 1.6

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:debian/smokeping
This branch contains Public information 
Everyone can see this information.

Subscribers