lp:debian/experimental/samba4

Created by James Westby on 2009-07-27 and last modified on 2013-02-16
Get this branch:
bzr branch lp:debian/experimental/samba4
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

27. By Andrew Bartlett on 2013-02-16

[ Andrew Bartlett ]
* Non-maintainer upload.
* New upstream relese: 4.0.3
 + Fixes CVE-2013-0172 Samba 4.0.0 as an AD DC may provide authenticated users
   with write access to LDAP directory objects
 + Fixes many other ACL related issues in the AD DC
 + Drop 08_waf_python_config as it is now upstream.
* Fix the forced use of NTVFS by setting the required options in the smb.conf
  at configure time.
* Add depenencies to ensure python-samba requires exactly this binary version
  of our core libraries. Closes: #700348

26. By Jelmer Vernooij on 2012-12-13

[ Martin Pitt ]
* debian/tests/control: Fix dependency: python-samba4 does not exist, it's
  python-samba. Closes: #695854

[ Jelmer Vernooij ]
* New upstream release: 4.0.0!
 + Add 08_waf_python_config to cope with python-config no longer
   being a script.
* Add 25_heimdal_api_changes, to update Samba to work with the
  current Heimdal in Sid. Patch from
  Samuel Cabrero Alam├ín <email address hidden>. Closes: #686227
* Add 11_force_ntvfs: Force the use of NTVFS, until the version of smbd in
  the archive is new enough. Closes: #694697
* Drop dependency on libsmbclient; instead, build private copy.

25. By Jelmer Vernooij on 2012-12-04

* New upstream release.
 + Drop 08_heimdal_config_h and 11_system_heimdal, now applied upstream.

24. By Jelmer Vernooij on 2012-11-08

* New upstream release.
* Add autopkgtest header. Closes: #692671
* Use Multi-Arch for winbind4.

23. By Jelmer Vernooij on 2012-10-28

* New upstream release.
 + Bump minimum ldb version to 1.1.13.
* Switch to Git as VCS.
* Remove DM-Upload-Allowed field.
* Depend on heimdal-multidev rather than heimdal-dev.
 + Add 11_system_heimdal to support building with system heimdal.

22. By Jelmer Vernooij on 2012-10-16

New upstream release.

21. By Jelmer Vernooij on 2012-10-04

* Depend on at least ldb 1.1.12. Closes: #689594
* Suggest ntp daemon for ntpsignd integration.
* Support specifying 'none' as server role to disable provision.
  Closes: #690138
* Prompt user for administrator password. Closes: #690139
* Bump debconf level of server role to 'high'.

20. By Jelmer Vernooij on 2012-09-25

New upstream release.

19. By Jelmer Vernooij on 2011-09-24

In -dev package dependencies, depend on a specific version of other
Samba dev packages.

18. By Jelmer Vernooij on 2011-09-18

* New upstream release.
* Add libsmbclient-{raw0,dev} packages, required for winexe.
* Add libsamba-credentials0 and libsamba-credentials-dev packages for
  new public library for credentials management.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers