lp:debian/experimental/hplip

Created by James Westby on 2010-12-24 and last modified on 2013-03-09
Get this branch:
bzr branch lp:debian/experimental/hplip
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

26. By Mark Purcell on 2013-03-09

* New Upstream Release
  - Fixes CVE-2013-0200 (Closes: #701185)
  - Fixes "hp-check does not find installed Xsane" (Closes: #690362)
* Ack NMU - Thanks Sebastian Ramacher

25. By Mark Purcell on 2012-12-08

New Upstream Release

24. By Mark Purcell on 2012-10-27

[ Till Kamppeter ]
* New upstream release
  - Fixed crash in HP Device Manager and System Tray due to ValueError
    exception in HPLIP upgrade functionality (LP: #1064889).
* debian/hplip.install, debian/hplip-gui.install: Added some missing program
  file links.
* debian/patches/hplip-release-parport.patch: libsane-hpaio does not close
  /dev/parport* after checking for a scanner (LP: #1065582, Red Hat bug
  #1065582).

[ Mark Purcell ]
* debian/bug-script: Fix bashism (Closes: #690625, #687243)

23. By Mark Purcell on 2012-10-06

* New upstream release
  - Fixes "Network scanning fails (Closes: #683033)
* quilt refresh hplip-syslog-fix-debug-messages-to-error.dpatch
* Fix "error in clean build env" updated debian/rules (Closes: #687129)

22. By Mark Purcell on 2011-01-27

* New Upstream Release
  - Fixes "CVE-2010-4267: Buffer overflow" (Closes: #610960)
* SECURITY UPDATE: denial of service and possible arbitrary code
  execution via long SNMP response

21. By Mark Purcell on 2010-12-23

New Upstream Release

20. By Evgeni Golov on 2010-10-20

* Non-maintainer upload.
* Try libhpmud.so.0 when libhpmud.so is not found.
  Closes: #600670

19. By Mark Purcell on 2010-07-24

* New Upstream Release
* NEW package libsane-hplip - headless scanner libs
* udev/rules.d/40-hplip.rules -> libhpmud0 - headless printing
* fixup debian/shlibs -> shlibs.libhpmud0

18. By Mark Purcell on 2010-07-03

* Force Depends: python (>> 2.6), python (<< 2.7) (Closes: #587737)
  - Urgency high for RC bug
* Ack python transition NMUs - Thanks Bernd

17. By Bernd Zeimetz on 2010-06-22

* Non-maintainer upload.
* Remove unnecessary module path option for dh_pysupport.
* Call dh_installdeb after dh_pysupport. This really
  closes: #585627

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:debian/squeeze/hplip
This branch contains Public information 
Everyone can see this information.

Subscribers