Code review comment for lp:~tsarev/percona-server/18205_03_wl47.patch

Oleg Tsarev (tsarev) wrote :

> Lines 4293--4925: no need to change it.
> Lines 4311--4315: likewise.

From my point of view more readable, but ok

> Lines 4351--4354: unmentioned functionality change?

See 4346--4357

> Lines 4404--4407: no need to change it.

I aligned agument of calls for this three functions for better readability

> Lines 4374--4378: unmentioned functinality change?

This is:
#define MYSQL_CLIENT
...
#endif // removed
// removed
#define MYSQL_CLIENT // removed
....

> Lines 4415--4440: likewise.

See Lines 4351--4354 and 4448--4461

> Lines 4448--4461: likewise.

See 4427--4440

> Lines 4469--4470: no need to change it.
> Lines 4478--4479: likewise.

According to MySQL Coding Guidelines I aligned right part of assigments. Do you need exact link and quote?

Quote:
http://forge.mysql.com/wiki/MySQL_Internals_Coding_Guidelines#Indentation_and_Spacing
When assigning to a variable, put zero spaces after the target variable name, then the assignment operator ('=' '+=' etc.), then space(s). For single assignments, there should be only one space after the equal sign. For multiple assignments, add additional spaces so that the source values line up. For example:

> Lines 4485--4486: I think the "before" code is actually correct. The
guidelines don't mention it, but there is an example there with it.
> Line 4617: one space after "=" (no need to align rvalues in this case)

Sorry, incorrectly understood part of Coding Guidelines. Will fix it.

review: Resubmit

« Back to merge proposal