Merge lp:~timo-jyrinki/ubuntu/trusty/qtmultimedia-opensource-src/drop_qtaudioengine into lp:ubuntu/trusty/qtmultimedia-opensource-src

Proposed by Timo Jyrinki on 2013-10-25
Status: Merged
Merged at revision: 11
Proposed branch: lp:~timo-jyrinki/ubuntu/trusty/qtmultimedia-opensource-src/drop_qtaudioengine
Merge into: lp:ubuntu/trusty/qtmultimedia-opensource-src
Diff against target: 70 lines (+8/-20)
3 files modified
debian/changelog (+7/-0)
debian/control (+1/-16)
debian/qtmultimedia5-examples.install (+0/-4)
To merge this branch: bzr merge lp:~timo-jyrinki/ubuntu/trusty/qtmultimedia-opensource-src/drop_qtaudioengine
Reviewer Review Type Date Requested Status
Timo Jyrinki Approve on 2013-10-29
Ubuntu branches 2013-10-25 Pending
Review via email: mp+192635@code.launchpad.net

Commit message

* Add libqt5multimedia5-plugins dependency to QML plugin (LP: #1202996)
  * Drop Qt Audio Engine for now to not bring OpenAL dependency

To post a comment you must log in.
Timo Jyrinki (timo-jyrinki) wrote :

Related to bug #1206268

Timo Jyrinki (timo-jyrinki) wrote :

Postponed to further discussion since it affects API we are providing in Touch, even if this would be needed to get desktop package migrate to main.

review: Disapprove
Michael Terry (mterry) wrote :

As of yesterday, we are no longer providing this API in Touch. I dropped the package from the ubuntu-sdk-libs metapackage. So this can go in.

Timo Jyrinki (timo-jyrinki) wrote :

Finally this was again approved together with approving the idea of now really doing the seed changes.

review: Approve
Timo Jyrinki (timo-jyrinki) wrote :

And the uploaded https://launchpad.net/ubuntu/+source/qtmultimedia-opensource-src/5.0.2-4ubuntu4 should get unblocked from proposed after the seed changes are in.

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
=== modified file 'debian/changelog'
--- debian/changelog 2013-07-02 17:52:51 +0000
+++ debian/changelog 2013-10-25 04:27:12 +0000
@@ -1,3 +1,10 @@
1qtmultimedia-opensource-src (5.0.2-4ubuntu4) trusty; urgency=low
2
3 * Add libqt5multimedia5-plugins dependency to QML plugin (LP: #1202996)
4 * Drop Qt Audio Engine for now to not bring OpenAL dependency
5
6 -- Timo Jyrinki <timo-jyrinki@ubuntu.com> Fri, 11 Oct 2013 08:13:50 +0300
7
1qtmultimedia-opensource-src (5.0.2-4ubuntu3) saucy; urgency=low8qtmultimedia-opensource-src (5.0.2-4ubuntu3) saucy; urgency=low
29
3 * debian/control: adding missing dependencies for qtmultimedia5-examples10 * debian/control: adding missing dependencies for qtmultimedia5-examples
411
=== modified file 'debian/control'
--- debian/control 2013-07-02 17:52:51 +0000
+++ debian/control 2013-10-25 04:27:12 +0000
@@ -17,7 +17,6 @@
17 libasound2-dev [linux-any],17 libasound2-dev [linux-any],
18 libpulse-dev,18 libpulse-dev,
19 libgstreamer-plugins-base0.10-dev,19 libgstreamer-plugins-base0.10-dev,
20 libopenal-dev,
21 libgstreamer0.10-dev,20 libgstreamer0.10-dev,
22 zlib1g-dev,21 zlib1g-dev,
23 pkg-kde-tools,22 pkg-kde-tools,
@@ -87,27 +86,13 @@
87Architecture: any86Architecture: any
88Multi-Arch: same87Multi-Arch: same
89Pre-Depends: dpkg (>= 1.15.6~), ${misc:Pre-Depends}88Pre-Depends: dpkg (>= 1.15.6~), ${misc:Pre-Depends}
90Depends: ${misc:Depends}, ${shlibs:Depends}89Depends: libqt5multimedia5-plugins, ${misc:Depends}, ${shlibs:Depends}
91Description: Qt 5 Multimedia QML plugin90Description: Qt 5 Multimedia QML plugin
92 Qt is a cross-platform C++ application framework. Qt's primary feature91 Qt is a cross-platform C++ application framework. Qt's primary feature
93 is its rich set of widgets that provide standard GUI functionality.92 is its rich set of widgets that provide standard GUI functionality.
94 .93 .
95 This package contains the Multimedia QML plugin for QtDeclarative.94 This package contains the Multimedia QML plugin for QtDeclarative.
9695
97Package: qtdeclarative5-qtaudioengine-plugin
98Architecture: any
99Multi-Arch: same
100Pre-Depends: dpkg (>= 1.15.6~), ${misc:Pre-Depends}
101Depends: ${misc:Depends}, ${shlibs:Depends}
102Conflicts: libqt5declarative5-qtmultimedia-plugin
103Replaces: libqt5declarative5-qtmultimedia-plugin
104Provides: libqt5declarative5-qtmultimedia-plugin
105Description: Qt 5 AudioEngine QML plugin
106 Qt is a cross-platform C++ application framework. Qt's primary feature
107 is its rich set of widgets that provide standard GUI functionality.
108 .
109 This package contains the AudioEngine QML plugin for QtDeclarative.
110
111Package: libqgsttools-p196Package: libqgsttools-p1
112Architecture: any97Architecture: any
113Multi-Arch: same98Multi-Arch: same
11499
=== modified file 'debian/qtmultimedia5-examples.install'
--- debian/qtmultimedia5-examples.install 2013-05-14 14:20:13 +0000
+++ debian/qtmultimedia5-examples.install 2013-10-25 04:27:12 +0000
@@ -11,10 +11,6 @@
11usr/lib/*/qt5/examples/multimedia/audiodevices/audiodevices.pro11usr/lib/*/qt5/examples/multimedia/audiodevices/audiodevices.pro
12usr/lib/*/qt5/examples/multimedia/audiodevices/audiodevicesbase.ui12usr/lib/*/qt5/examples/multimedia/audiodevices/audiodevicesbase.ui
13usr/lib/*/qt5/examples/multimedia/audiodevices/main.cpp13usr/lib/*/qt5/examples/multimedia/audiodevices/main.cpp
14usr/lib/*/qt5/examples/multimedia/audioengine/audioengine.pro
15usr/lib/*/qt5/examples/multimedia/audioengine/qml/audioengine.qml
16usr/lib/*/qt5/examples/multimedia/audioengine/qml/audioengine.qmlproject
17usr/lib/*/qt5/examples/multimedia/audioengine/qml/content/MyAudioEngine.qml
18usr/lib/*/qt5/examples/multimedia/audioinput/audioinput14usr/lib/*/qt5/examples/multimedia/audioinput/audioinput
19usr/lib/*/qt5/examples/multimedia/audioinput/audioinput.cpp15usr/lib/*/qt5/examples/multimedia/audioinput/audioinput.cpp
20usr/lib/*/qt5/examples/multimedia/audioinput/audioinput.h16usr/lib/*/qt5/examples/multimedia/audioinput/audioinput.h

Subscribers

People subscribed via source and target branches

to all changes: