Code review comment for lp:~therp-nl/banking-addons/ba61-company_awareness_bank_import_settings

Revision history for this message
Alexandre Fayolle - camptocamp (alexandre-fayolle-c2c) wrote :

nitpicking (line numbers refer the to preview diff)

line 8: missing space after colon

line 29: it looks like all other methods in that file use "cr" as argument name. Time to make this one conform with the convention?

line 35-38: this is verging on abuse, IMO. I much prefer something like

if user['company_id']:
    return user['company_id'][0]
else:
    company_ids = self.pool.get('res.company').search(
                         cursor, uid, [('parent_id', '=', False)])
    return company_ids[0]

in the XML, I think using '!=' rather than '<>' is much nicer

Nothing blocking in the above.

review: Approve (code review, no test)

« Back to merge proposal