lp:~stub/ubuntu/xenial/python-support/rebuild

Created by Stuart Bishop on 2016-07-04 and last modified on 2016-07-04
Get this branch:
bzr branch lp:~stub/ubuntu/xenial/python-support/rebuild
Only Stuart Bishop can upload to this branch. If you are Stuart Bishop please log in for upload directions.

Related bugs

Related blueprints

Branch information

Owner:
Stuart Bishop
Status:
Development

Recent revisions

37. By Piotr Ożarowski on 2012-06-30

[ Jakub Wilk ]
* parseversions:
  + Make comparison of field names case-insensitive.
  + Recognize X-Python-Version.

[ Piotr Ożarowski ]
* update-python-modules manpage: fix --install option's description
  (closes: #671942)
* movemodules:
  - doesn't raise string exceptions anymore (closes: #585332)
* Standards version is 3.9.3, no changes required

36. By Barry Warsaw on 2011-10-21

update-maintainer

35. By Barry Warsaw on 2011-10-21

Based on IRC discussion, manually sync to Debian 1.0.14, dropping the
Ubuntu delta. After next Debian upload, please resync for real.

34. By Barry Warsaw on 2011-10-21

* Merge with Debian testing. Remaining Ubuntu changes:
  - movemodules, update-python-modules, debhelper/dh_pysupport:
    Add support for --prefix. This is used for example, by Quickly to
    install modules into /opt/extras.ubuntu.com/<appname>-version/
* update-python-modules: remove directory if it's replaced with a file
  (often happens with .egg-info file/dirs)
* Add deprecation warning: dh_python2 (from python package) should be used
  instead. Migration guide is available on wiki page:
  http://wiki.debian.org/Python/PythonSupportToDHPython2
* Vcs-* fields now point to anonscm.debian.org
* Standards version is 3.9.2, no changes required.

33. By Barry Warsaw on 2011-05-27

* Merge with Debian; remaining changes:
  - movemodules, update-python-modules, debhelper/dh_pysupport:
    Add support for --prefix. This is used for example, by Quickly to
    install modules into /opt/extras.ubuntu.com/<appname>-version/
* tests/testparseversions.py: don't hardcode expected versions; instead,
  compare with pyversions' output.
* pysupport.py: don't hardcode supported and old versions; instead, parse
  debian_defaults; NB: this removes some very old python versions from the
  list (2.1 and 2.2), but these weren't ever support and aren't supported in
  the previous stable release anyway. Depend on python-minimal as
  debian_defaults is accessed directly.
* Upload to unstable (closes: #622906)
* Add lintian override for depends-on-python-minimal
* Add support for python2.7.
* Move python2.4 to old versions.
* Move python2.4 to old versions.

32. By Didier Roche on 2010-11-11

* movemodules, update-python-modules, debhelper/dh_pysupport:
  - add support for --prefix

31. By Barry Warsaw on 2010-10-20

Add support for Python 2.7. (LP: #664068).

30. By Loïc Minier on 2010-10-13

* Merge with Debian; remaining changes:
  - Move python2.4 and 2.5 to oldversions.

29. By Mikhail Turov on 2010-07-20

* Merge with Debian; LP: #607828; remaining changes:
  - Move python2.4 and 2.5 to oldversions.

28. By Loïc Minier on 2010-05-22

Drop leftover .bzr*.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers