patchwork:pyup-pin-sqlparse-0.3.1

Last commit made on 2020-02-29
Get this branch:
git clone -b pyup-pin-sqlparse-0.3.1 https://git.launchpad.net/patchwork

Branch merges

Branch information

Name:
pyup-pin-sqlparse-0.3.1
Repository:
lp:patchwork

Recent commits

5dbab5a... by pyup-bot <email address hidden> on 2020-02-29

Pin sqlparse to latest version 0.3.1

60cc660... by pyup-bot <email address hidden> on 2020-02-29

Pin sqlparse to latest version 0.3.1

563557a... by Stephen Finucane <email address hidden> on 2020-02-28

docs: Reference current list-id

We've updated our fixtures to use this newer version, meaning we no
longer need to pass an explicit '--list-id' argument. Lovely.

Signed-off-by: Stephen Finucane <email address hidden>
Fixes: 9a0b5992 ("fixtures: Update Patchwork list ID")

bd21a06... by Stephen Finucane <email address hidden> on 2020-02-27

Add support for djangorestframework 3.11

There are no breaking changes apparent.

Signed-off-by: Stephen Finucane <email address hidden>

2f7a0b9... by pyup-bot <email address hidden> on 2020-01-30

Update jinja2 from 2.10.1 to 2.11.1

eee67b4... by Stephen Finucane <email address hidden> on 2020-02-27

tox: Switch non-pyNN targets to Python 3

This is long overdue and highlights a small issue, which is easily fixed
by use of Sphinx.

Signed-off-by: Stephen Finucane <email address hidden>

5b904f9... by Daniel Axtens on 2020-01-28

pyenv: also install requirements for python2

The first time you do a migration with python3, you get a whole
lot of seemingly null changes. This is a bit annoying so I use
py2 to generate the changes. To do that, first fix the pyenv
transition so requirements are still installed for python2.

Signed-off-by: Daniel Axtens <email address hidden>
Reviewed-by: Stephen Finucane <email address hidden>

46bd25f... by Stephen Finucane <email address hidden> on 2020-02-27

docs: Update schemas to reflect latest changes in template

Looks like I forgot to run the 'generate-schema' script beforehand. Fix
that now.

Signed-off-by: Stephen Finucane <email address hidden>
Fixes: cd3a2ce8 ("REST: Allow configuration of user settings via API")

00dce05... by Pranav Annam <email address hidden> on 2020-02-12

docker: update dependency for current build

The dependency libssl1.0-dev in the Dockerfile makes docker build fail:

  The following packages have unmet dependencies:
   libmysqlclient-dev : Depends: libssl-dev (>= 1.1.1-1ubuntu2.1~18.04.5~)
  but it is not going to be installed
  E: Unable to correct problems, you have held broken packages.

There seems to be a conflict with different versions of libssl and
libmysqlclient that did not exist previously with Ubuntu 18.04.

Just use the current libssl-dev from Ubuntu 18.04 to fix the build.

Signed-off-by: Pranav Annam <email address hidden>
[rephrased commit message]
Signed-off-by: Lukas Bulwahn <email address hidden>
Signed-off-by: Daniel Axtens <email address hidden>

1c31bb5... by Pranav Annam <email address hidden> on 2020-02-12

docs: set the GID in the .env file

The .env file needs the UID and GID for a working docker-compose build.

If you follow the current instructions, the docker build fails with a
clear error message: 'You must define GID in .env'

It is still good to update documentation to reduce the burden on new
contributors to run into this build failure first.

Signed-off-by: Pranav Annam <email address hidden>
[simply provide bash command in docs, reworked commit message]
Signed-off-by: Lukas Bulwahn <email address hidden>
Signed-off-by: Daniel Axtens <email address hidden>