~smoser/ssh-import-id:fix/debian/control-vcs-git

Last commit made on 2020-02-10
Get this branch:
git clone -b fix/debian/control-vcs-git https://git.launchpad.net/~smoser/ssh-import-id
Only Scott Moser can upload to this branch. If you are Scott Moser please log in for upload directions.

Branch merges

Branch information

Name:
fix/debian/control-vcs-git
Repository:
lp:~smoser/ssh-import-id

Recent commits

4551223... by Scott Moser

debian/control: Update vcs fields after move to git.

The debian/control Vcs-Browser and Vcs-git have not been updated
after moving to git on launchpad. They still pointed to bzr locations.

4001a38... by Scott Moser

debian/postinst: Correctly check old version.

The postinst check for version was not working properly, as it
referenced an un-defined variable.

a595d2a... by Scott Moser

tools: Do not use --tags with git-describe.

I've signed 5.7 now and will intend to annotate future tags,
so the --tags is not necessary in these tools.

d7b265c... by Scott Moser

debian/: Adjust packaging to include debian's changes.

This just takes changes that are in debian's sid branch.
  debian/compat: 9 -> 10
  debian/control:
    - debhelper: 8 -> 10
    - drop shlibs dep.
    - drop X-Python3-Version: ssh-import-id will work on
      any supported python.

All differences at this point are improvements on this side.
  - python3-all: does not need a versioned depends. No supported version
     of python3-all is <2.6.
  - standards-version: this value is newer than in debian. (4.1.3->4.1.2)
  - postinst: safer updating of obsolete config here.
  - debian/install: have a trailing newline.
  - debian/rules: patch the version into version.py so we get the
    packaged version.
  - debian/source/format: declare version 3.0 quilt.

bf3d1fd... by Scott Moser

Get path to user's authorized_keys even if HOME is not set.

Previous attempt to fix bug 1570997 failed.
They only addressed the read portion of the code, not the writing.
This provides a method 'get_keyfile' and uses it in both places.

LP: #1570997

33242b8... by Scott Moser

tox: enable running of pylint.

All pylint errors are now either skipped or fixed.

32874cf... by Michael Hudson-Doyle

Exit with sys.exit() rather than os._exit.

When exiting witih os._exit, error messages were not guaranteed
to be flushed.

LP: #1770302

ca6d90e... by Michael Hudson-Doyle

Launchpad: check status code of response when fetching ssh keys.

This gives a nicer message on a non existing user.

LP: #1770305

a733f11... by Scott Moser

github: Handle errors differently check and report status_code.

The rate-limiting doc at
  https://developer.github.com/v3/#rate-limiting
Says that status code on rate limit deny will be 403.
The change here requires that it be not 200.

6bbd531... by Scott Moser

main: simplify the final exception handling.

Simple change to just catch the exception rather than using sys.exc_info().