lp:~sil2100/update-manager/ignore_prompt_lts_for_non-lts

Created by Łukasz Zemczak on 2018-08-28 and last modified on 2018-08-30
Get this branch:
bzr branch lp:~sil2100/update-manager/ignore_prompt_lts_for_non-lts
Only Łukasz Zemczak can upload to this branch. If you are Łukasz Zemczak please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Łukasz Zemczak
Project:
Software Updater
Status:
Merged

Recent revisions

2830. By Łukasz Zemczak on 2018-08-30

Proposition: since MetaRelease.py uses distro-info now, I guess it's most logical to make it depend on it?

2829. By Łukasz Zemczak on 2018-08-29

Stop using 'type' as a variable name. It's a bad python variable name.

2828. By Łukasz Zemczak on 2018-08-29

Small correction in a comment.

2827. By Łukasz Zemczak on 2018-08-28

Ignore Prompt=lts for non-LTS series. This way if a user is on a non-LTS and has Prompt=lts, he/she will be upgraded to the next supported series until finally reaching an LTS.

2826. By Julian Andres Klode on 2018-06-27

releasing package update-manager version 1:18.10.3

2825. By Julian Andres Klode on 2018-06-27

Add support for HTTPS proxies; this breaks UpdateManager.Core.utils.init_proxy()
APIthe return value is now a dict, rather than a string (LP: #1771914).

2824. By Mathieu Trudel-Lapierre on 2018-06-08

releasing package update-manager version 1:18.10.2

2823. By Mathieu Trudel-Lapierre on 2018-06-08

Fix my spelling mistake in the previous upload. Oops.

2822. By Steve Langasek on 2018-05-30

Fix code comment to document the actual proxy behavior, which is correct.

2821. By Mathieu Trudel-Lapierre on 2018-05-28

releasing package update-manager version 1:18.10.1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:update-manager
This branch contains Public information 
Everyone can see this information.

Subscribers