Merge lp:~saviq/unity-api/cross-and-wrap into lp:unity-api

Proposed by Michał Sawicz on 2015-02-10
Status: Merged
Approved by: Michi Henning on 2015-02-10
Approved revision: 167
Merged at revision: 167
Proposed branch: lp:~saviq/unity-api/cross-and-wrap
Merge into: lp:unity-api
Diff against target: 48 lines (+12/-7)
1 file modified
debian/control (+12/-7)
To merge this branch: bzr merge lp:~saviq/unity-api/cross-and-wrap
Reviewer Review Type Date Requested Status
Michi Henning (community) 2015-02-10 Approve on 2015-02-10
Review via email: mp+249158@code.launchpad.net

Commit message

Add :native to g++ dependency for cross-building and wrap-and-sort for good measure. Python needs :any, too.

To post a comment you must log in.
lp:~saviq/unity-api/cross-and-wrap updated on 2015-02-10
167. By Michał Sawicz on 2015-02-10

Python → any

Michi Henning (michihenning) wrote :

Yes, thank you!

review: Approve
Michi Henning (michihenning) wrote :

I'm sort of hamstrung on this one. Could we please land it as a matter of urgency?

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'debian/control'
2--- debian/control 2014-07-01 00:43:05 +0000
3+++ debian/control 2015-02-10 08:44:27 +0000
4@@ -2,23 +2,28 @@
5 Priority: optional
6 Section: libs
7 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
8-Build-Depends: g++-4.9,
9+Build-Depends: cmake,
10 debhelper (>= 9),
11- cmake,
12 doxygen,
13+# We rely on C++11 features, and to prevent from ABI breaks
14+# in libstdc++ causing us issues, we explicitly select a G++
15+# version. To allow cross-compiling to work, we also must
16+# append :native to g++-4.9 so we don't try to run armhf g++
17+# on an x86 CPU for example, when cross-compiling.
18+ g++-4.9:native,
19 graphviz,
20+ libboost-dev (>= 1.49),
21 libboost-regex-dev (>= 1.49),
22- libboost-dev (>= 1.49),
23+ libglib2.0-dev,
24 libgtest-dev,
25 pkg-config,
26- python3,
27+ python3:any,
28 qt5-default,
29 qtbase5-dev,
30 qtdeclarative5-dev,
31 qtdeclarative5-dev-tools,
32 qtdeclarative5-qtquick2-plugin,
33 qtdeclarative5-test-plugin,
34- libglib2.0-dev,
35 Standards-Version: 3.9.4
36 Homepage: https://launchpad.net/unity-api
37 # If you aren't a member of ~unity-team but need to upload
38@@ -40,9 +45,9 @@
39 Section: libdevel
40 Architecture: any
41 Multi-Arch: same
42-Depends: ${misc:Depends},
43- libboost-dev (>= 1.49),
44+Depends: libboost-dev (>= 1.49),
45 libunity-api0 (= ${binary:Version}),
46+ ${misc:Depends},
47 Description: Header files for Unity API
48 Library to integrate with the Unity shell (dev files)
49

Subscribers

People subscribed via source and target branches

to all changes: