lp:~saviq/kubuntu-packaging/qtbase-backport-8cf9811e

Created by Michał Sawicz on 2014-01-31 and last modified on 2014-01-31
Get this branch:
bzr branch lp:~saviq/kubuntu-packaging/qtbase-backport-8cf9811e
Only Michał Sawicz can upload to this branch. If you are Michał Sawicz please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Michał Sawicz
Project:
kubuntu-packaging
Status:
Development

Recent revisions

144. By Albert Astals Cid on 2014-01-31

Backport QIconLoader fix from qtbase/stable.

143. By Timo Jyrinki on 2014-01-23

* Cherry-pick qdoc-Fix-crash-in-Generator-generateInnerNode.patch:
  - Fix qdoc with libhud-qt (LP: #1271036)

142. By Timo Jyrinki on 2014-01-17

update qtbase5-dev.install-common since the aarch64 patches were dropped

141. By Timo Jyrinki on 2014-01-17

Sync with archive

* Build-depends on libxcb-sync-dev instead of libxcb-sync0-dev.
* No change rebuild against libxcb-sync1

140. By Timo Jyrinki on 2014-01-13

Drop aarch64 patches that are reportedly not needed anymore

< doko> did you ask me about the arm64 patches?
< doko> checked. can be dropped

139. By Timo Jyrinki on 2014-01-13

Sync with archive 5.0.2 uploads

* No change rebuild against libicu52
* Positively restrict libopenvg1-mesa-dev build-dependency to only those
  architectures where it is built (matching the mesa source), rather than
  trying to simulate this with negative architecture restrictions.
* Drop [!arm64] restriction on libpulse-dev; we have libpulse-dev/arm64
  now.
* Disable gdb build-dependency on ppc64el for now, until we have a working
  gdb there.

138. By Timo Jyrinki on 2013-12-19

* Cherry-pick two submitted patches to support appmenu-qt: (LP: #1157213)
  - make_qkdetheme_constructor_public.diff
  - platformtheme_env.diff
    + make_qkdetheme_constructor_public.diff
    + platformtheme_env.diff

137. By Timo Jyrinki on 2013-12-13

* Sync with Debian 5.2.0+dfsg-1, additional remaining changes:
  - No openvg or libpulse-dev dependency on arm64
    + Do-not-disable-egl-on-desktop-gl-automatically.patch
    + xcb_use_quint32.patch

[ Dmitry Shachnev ]
* Fix two wrongly sorted lines in qtbase5-private-dev.install (thanks Timo).
* Do not list armhf-specific paths in qtbase5-dev.install-armel.
[ Lisandro Damián Nicanor Pérez Meyer ]
* New upstream release.
* Update install files.
* Update symbols files, marking private symbols as such.
* Remove Disallow_deep_or_widely_nested_entity_references.patch, it has been
  applied upstream.
* Upstream made all archs use double for qreal (see #731261 for more
  context).
  - Rename libqt5core5 to libqt5core5a to help in the transition:
    - Make libqt5core5a break and replace libqt5core5 << 5.2.0+dfsg~.
    - Rename the associated files (install, lintian-overrides and symbols).
    - Adjust dependencies in debian/control.
    - Add lintian override for package not matching SONAME.
  - Re create symbols that used the qreal subst, they are now all doubles.
* A user of Qt built by a distro doesn't needs to find where the SQL plugins
  are via CMake. Do not install them (Closes: #729602).
* Backport Disallow_deep_or_widely_nested_entity_references.patch to fix
  CVE-2013-4549: XML Entity Expansion Denial of Service. Set severity
  to high.
* Update symbols files with buildds' logs.

136. By Timo Jyrinki on 2013-12-12

Remove missing symbols.

135. By Timo Jyrinki on 2013-12-12

mark private symbols

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers