lp:~saiarcot895/chromium-browser/chromium-browser.xenial.dev

Created by Saikrishna Arcot on 2016-02-29 and last modified on 2016-06-11
Get this branch:
bzr branch lp:~saiarcot895/chromium-browser/chromium-browser.xenial.dev
Only Saikrishna Arcot can upload to this branch. If you are Saikrishna Arcot please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Saikrishna Arcot
Project:
Chromium Browser
Status:
Mature

Recent revisions

368. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-30

Disable ozone, because it's not yet ready.

367. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-27

* Add X11 libraries and Wayland libraries to list of libraries to
  compile with.
* Add patch to fix compiling pdfium with XFA support enabled on armhf
  and arm64.

366. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-27

Fix 5-desktop-integration-settings.patch.

365. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-26

* Add in missing part of VAAPI patch.
* Add some #ifdef's around parts of code that aren't meant for arm.

364. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-26

Fixes to libva patch.

363. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-26

* New upstream version 52.0.2743.6
* Build using ozone as the UI layer (experimental), and add wayland
  support.
* Remove arm support for hardware video decoding (it probably doesn't
  work, since it needs additional support).
* Don't fail the pre-sandbox policy check if hardware video decoding
  libraries don't get loaded correctly.
* Updated patches.

362. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-24

Add necessary libva config.

361. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-23

* More work on support for Precise.
* Remove refereces to system headers of libva, and restore va config.

360. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-22

* Work on support for Precise.
* Update path to ffmpeg.so library.
* Don't use the libva-dev package, and use the headers that upstream
  is using. The library is dlopen'ed anyways.

359. By Saikrishna Arcot <saikrishna@saikrishna-vps> on 2016-05-22

* Try to bring back support for Precise.
* Add detection code to see if VP9 is available on the target system.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers