lp:~rperier/language-selector/kcm

Created by Romain Perier and last modified
Get this branch:
bzr branch lp:~rperier/language-selector/kcm
Only Romain Perier can upload to this branch. If you are Romain Perier please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Romain Perier
Project:
language-selector
Status:
Mature

Recent revisions

426. By Romain Perier on 2011-02-24

* LanguageSelector/qt/QtLanguageSelector.py:
 - Disable and uncheck installable components on tab change, which are confusing
 - Code cleanup in self.onTabChangeRevertApply()

425. By Martin Pitt on 2011-02-24

releasing version 0.18

424. By Martin Pitt on 2011-02-24

Restore changes from 0.15 which were accidentally dropped in 0.17 due to
bzr branch confusion.

423. By Martin Pitt on 2011-02-24

releasing version 0.17

422. By Martin Pitt on 2011-02-24

* Clean up after the gratutitous renaming in 0.14:
  - Bring back language-selector as transitional package for l-s-gnome.
  - Fix Conflicts/Replaces: to be versioned
  - Put transitional packages in section oldlibs.

421. By Jonathan Thomas on 2011-02-24

Create a transitional binary package for language-selector-qt to install
language-selector-kde. Otherwise language-selector-qt just gets
uninstalled and international users are just left hanging.

420. By Jonathan Thomas on 2011-02-24

Sync packaging with the archive

419. By Jonathan Riddell on 2011-02-23

* LanguageSelector/qt/QtLanguageSelector.py:
 - Unapply changes on changing tab
* data/incomplete-language-support-kde.note.in
 - Run kcontrol module

418. By Jonathan Riddell on 2011-02-23

tidy up control file

417. By Jonathan Riddell on 2011-02-23

* LanguageSelector/qt/QtLanguageSelector.py:
  - KCModule and kcontrol migration
  - Add same features than gtk frontend
  - New GUI
  - Migrate to polkit (no longer runs as root)
* dbus_backend/com.ubuntu.languageselector.policy.in:
  - Change policy to auth_admin_keep (avoids multiple polkit authentifications)
* debian:
  - Rename language-selector => language-selector-gnome
  - Rename language-selector-qt => language-selector-kde
  - Drop language-selector-qt.1 (not required anymore)
* data/qt-language-selector.desktop.in:
  - Rename to kde-language-selector
  - Make changes to be a kcmodule

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:language-selector
This branch contains Public information 
Everyone can see this information.

Subscribers