Merge lp:~roadmr/canonical-identity-provider/dependencies-upgrade-django-statsd into lp:~ubuntuone-pqm-team/canonical-identity-provider/dependencies

Proposed by Daniel Manrique
Status: Needs review
Proposed branch: lp:~roadmr/canonical-identity-provider/dependencies-upgrade-django-statsd
Merge into: lp:~ubuntuone-pqm-team/canonical-identity-provider/dependencies
Diff against target: 4 lines (+0/-0)
0 files modified
To merge this branch: bzr merge lp:~roadmr/canonical-identity-provider/dependencies-upgrade-django-statsd
Reviewer Review Type Date Requested Status
Adam Collard (community) Approve
Review via email: mp+347401@code.launchpad.net

Commit message

Add raven 6.9.0 and its required contextlib2 upgrade.

Description of the change

Add raven 6.9.0 and its required contextlib2 upgrade.

I reused this branch to avoid the ridiculousness of having to reupload the entire dependencies branch at over 150 MB just to update two measly deps :)

To post a comment you must log in.
86. By Daniel Manrique

Update raven to 6.9.0 for better Django 1.11-ness

Revision history for this message
Adam Collard (adam-collard) wrote :

Daniel, is this still required?

Revision history for this message
Daniel Manrique (roadmr) wrote :

I think so, the main goal is updating raven which works better with django 1.11 and removes deprecation warnings when running under django 2.0. I wanted to start upgrading dependencies slowly to eventually move SSO to django 2.x and onwards to python3.

But maybe we want a bigger push toward that goal, which would likely cover this kind of thing.

I'll check if things still work well and maybe merge this.

Revision history for this message
Adam Collard (adam-collard) :
review: Approve

Unmerged revisions

86. By Daniel Manrique

Update raven to 6.9.0 for better Django 1.11-ness

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== added file 'contextlib2-0.5.5-py2.py3-none-any.whl'
2Binary files contextlib2-0.5.5-py2.py3-none-any.whl 1970-01-01 00:00:00 +0000 and contextlib2-0.5.5-py2.py3-none-any.whl 2018-06-04 19:13:32 +0000 differ
3=== added file 'raven-6.9.0-py2.py3-none-any.whl'
4Binary files raven-6.9.0-py2.py3-none-any.whl 1970-01-01 00:00:00 +0000 and raven-6.9.0-py2.py3-none-any.whl 2018-06-04 19:13:32 +0000 differ

Subscribers

People subscribed via source and target branches