lp:~ricotz/libgnome/ubuntu

Created by Rico Tzschichholz on 2011-12-14 and last modified on 2011-12-14
Get this branch:
bzr branch lp:~ricotz/libgnome/ubuntu
Only Rico Tzschichholz can upload to this branch. If you are Rico Tzschichholz please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Rico Tzschichholz
Project:
libgnome
Status:
Development

Recent revisions

25. By Rico Tzschichholz on 2011-12-14

* Merge with debian, remaining changes:
  - debian/libgnome2-common.gconf-defaults:
    + changes to default configuration for Ubuntu, drop the keys for
      themes which are also set in the ubuntu-artwork defaults
  - debian/patches/08_dont_force_a11y_activation.patch:
    + don't force a11y activation
  - debian/patches/10_sounds_event_list.patch:
    + no sound event out of the login one for the default configuration
  - debian/control.in: Demote gvfs from Depends to Recommends:. It is
    necessary under GNOME for proper xdg-open integration (see Debian
    #519263), but not needed when running under e. g. XFCE.
  - debian/control.in:
    + Build-depend on dh-autoreconf and gnome-common
  - debian/rules:
    + Use autoreconf.mk
* Bump Standards-Version to 3.9.2. No further changes.
* Bump debhelper compatibility level to 8:
  - Update Build-Depends on debhelper.
  - Strip debian/tmp/ from .install files.
* debian/libgnome2-dev.install
  - Remove libtool .la file.
* debian/rules
  - Remove clean-la.mk include.
  - Create a header file containing DEB_HOST_MULTIARCH.
* debian/patches/03_multiarch.patch
  - Look for accessibility modules in multiarch directories. Closes: #636197
* debian/control
  - Add Suggests: devhelp to libgnome2-doc for the gtk-doc API
    documentation.
  - Remove obsolete Conflicts and Replaces.
* New upstream release.
* Switch to 3.0 quilt format.
* Watch for tar.bz2 files.
* Build-depend on libcanberra instead of libesd.
* 00_as-needed.patch, 02_path_max.patch: refreshed.
* libgnome2-common.gconf-defaults: set default cursor theme to
  Adwaita, to match the default in gsettings-desktop-schemas. In GNOME
  3, g-s-d uses GSettings to read the theme, while metacity/mutter
  still use GConf.
* Update -dev dependencies according to the .pc file.

24. By Robert Ancell on 2011-04-06

releasing version 2.32.1-0ubuntu3

23. By Martin Pitt on 2011-03-31

releasing version 2.32.1-0ubuntu2

22. By Martin Pitt on 2011-03-30

Set Banshee as default media player (LP: #735372)

21. By Sebastien Bacher on 2011-02-03

releasing version 2.32.1-0ubuntu1

20. By Sebastien Bacher on 2011-02-03

* New upstream version
* debian/control.in:
  - drop the libaudiofile-dev build-depends it's not required
  - updated the standards version

19. By Sebastien Bacher on 2010-09-27

releasing version 2.32.0-0ubuntu1

18. By Sebastien Bacher on 2010-08-18

releasing version 2.31.0-0ubuntu2

17. By Sebastien Bacher on 2010-08-18

debian/control.in: libgnome2-dev requires libcanberra-dev not libesd0-dev

16. By Robert Ancell on 2010-08-17

* New upstream release
* debian/control:
  - Build-depend on dh-autoreconf and gnome-common
  - Add build-depend on libcanberra-dev, drop build-depend on libesd0-dev
* debian/source:
  - Use source version 3.0
* debian/rules:
  - Drop simple-patchsys.mk
  - Use autoreconf.mk

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:libgnome
This branch contains Public information 
Everyone can see this information.