lp:~raoul-snyman/openlp/db-upgrades

Created by Raoul Snyman on 2011-08-25 and last modified on 2011-08-25
Get this branch:
bzr branch lp:~raoul-snyman/openlp/db-upgrades
Only Raoul Snyman can upload to this branch. If you are Raoul Snyman please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Raoul Snyman
Project:
OpenLP
Status:
Merged

Recent revisions

1725. By Raoul Snyman on 2011-08-25

A few more tweaks as requested by Andreas.

1724. By Raoul Snyman on 2011-08-25

Fixed a bug where the version number saved to the database was incorrect. Added the ability to throw an error message and not load the database if the db is too new or incorrect.

1723. By Raoul Snyman on 2011-08-25

Added migrate dependency to deb package.

1722. By Raoul Snyman on 2011-08-25

Now with exception handling.

1721. By Raoul Snyman on 2011-08-25

Even better, got rid of 'upgrade_schema' function which is not really needed.

1720. By Raoul Snyman on 2011-08-25

Database upgrading, revision 1.

1719. By Andreas Preikschat on 2011-08-24

- use urllib.urlretrieve to download ts files

1718. By Andreas Preikschat on 2011-08-21

- changed menu shortcut letter

1717. By Andreas Preikschat on 2011-08-21

- updated i18n files

1716. By Raoul Snyman on 2011-08-20

Fixed bug #825809 where SQLAlchemy 0.7 throws a 'ArgumentError: SQL expression object or string expected' when passed something other than an SQL expression object or a string.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar RepositoryFormatKnitPack5RichRoot (bzr 1.6.1)
Stacked on:
lp:openlp
This branch contains Public information 
Everyone can see this information.

Subscribers