Mir

Code review comment for lp:~raof/mir/the-least-dirty-thing

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Minor observations so far:

(1) 18 +Package: libmirclient-debug
is potentially confusing with the existing convention: packagename-dbg
so I think the dash needs removing. Something like "libmirclienttesting", since it's really not about "debugging" Mir at all.

(2) It seems we're going backwards in code bloat faster than I can keep up with fixing it. Can we avoid this part?
176 +
177 +# TODO: Extension apparatus so that mirclient-debug can be a MODULE and not
178 +# duplicate (almost) the entirity of mirclient
179 +add_library(
180 + mirclient-debug SHARED
181 +
182 + mir_debug_api.cpp
183 + $<TARGET_OBJECTS:mirclientobjects>
184 +)

(3) The amount of coupling we have is a bit excessive. Or is that an existing issue imposed by the existing class design?; "make_mediator()"

review: Needs Fixing

« Back to merge proposal