lp:~pythonxy/pythonxy-upstream/qgrid

Created by dacoex on 2014-11-23 and last modified on 2016-12-26
Get this branch:
bzr branch lp:~pythonxy/pythonxy-upstream/qgrid

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Python XY
Project:
Upstream Package Updates for PythonXY
Status:
Development

Import details

Import Status: Failed

This branch is an import of the HEAD branch of the Git repository at git://github.com/quantopian/qgrid.git.

The import has been suspended because it failed 5 or more times in succession.

Last successful import was on 2016-12-27.

Import started on 2016-12-31 on pear and finished on 2016-12-31 taking 15 seconds — see the log
Import started on 2016-12-29 on pear and finished on 2016-12-29 taking 15 seconds — see the log
Import started on 2016-12-28 on pear and finished on 2016-12-28 taking 15 seconds — see the log
Import started on 2016-12-27 on pear and finished on 2016-12-27 taking 20 seconds — see the log

Recent revisions

118. By Tim Shawver <email address hidden> on 2016-12-26

Merge pull request #96 from smarkets/master

Add an export mode to enable qgrid in notebooks exported to Html files

117. By Tim Shawver <email address hidden> on 2016-12-26

Merge pull request #89 from hottwaj/master

Added option 'height' that allows control over qgrid height

116. By Tim Shawver <email address hidden> on 2016-06-20

Use a specific revision in the rawgit CDN url, because rawgit caches files permanently, so remote_js=True would have resulted in using old javascript.

115. By Tim Shawver <email address hidden> on 2016-06-20

Miscellaneous fixes (#84)

* Fixing a few issues. Most notably the dates being converted to local time, causing them to seem like they're off by a day in the demo notebook.

* Remove add/remove buttons from sample notebook since they're not working in most cases, make text filter dropdown scroll, and give it a top border.

* Update docs to call adding/removing rows experimental, and to point to the new sample notebook on nbviewer.

114. By Tim Shawver <email address hidden> on 2016-06-13

Changes for 0.3.2 release (#82)

* A few changes we'll want to make when we tag a branch with 0.4.0 for release on pypi.

* Let's call this release 0.3.2 since there aren't any new features, just compatibility changes.

113. By Tim Shawver <email address hidden> on 2016-06-05

Make qgrid compatible with ipywidgets 5 and jupyter notebook 4.2.x (#81)

* Changes to make qgrid compatible with ipywidgets 5 and jupyter notebook 4.2.x

* Fix compatibility grid.

* wip

* wip

112. By Tim Shawver <email address hidden> on 2016-06-05

Qgrid still works on python 2. I ran into a jupyter notebook bug which confused me and made me think it wasn't working on python 2.

111. By Tim Shawver <email address hidden> on 2016-06-05

Revert "Fixing docs, regarding python2 compatibility" (#80)

110. By Tim Shawver <email address hidden> on 2016-06-04

Fixing docs, regarding python2 compatibility (#79)

Qgrid is still compatible with Python 2. I mistakenly removed that from the docs because the sample notebook wasn't working with python 2, since it was saved with a python 3 kernel. To prevent other people from running into that problem I've added a separate version of the sample notebook that I saved with a python 2 kernel, and updated the docs accordingly.

109. By Tim Shawver <email address hidden> on 2016-06-04

Merge pull request #78 from quantopian/compatibility-issues

Updating docs and requirements.txt to reflect compatibility issues

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers

No subscribers.