lp:~pguimaraes/landscape-client-charm/landscape-client-charm

Created by Pedro Guimarães on 2018-11-26 and last modified on 2018-11-26
Get this branch:
bzr branch lp:~pguimaraes/landscape-client-charm/landscape-client-charm
Only Pedro Guimarães can upload to this branch. If you are Pedro Guimarães please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Pedro Guimarães
Project:
landscape-client-charm
Status:
Development

Recent revisions

68. By Pedro Guimarães on 2018-11-26

As per lp:1796967, python2 is the interpreter of choice for Xenial.
However, lds-client 18.03 comes on python3-only libs, so running on Xenial
is not possible with current charms.
Python3 can be chosen as interpreter for Xenial if landscape client
is running on any version above 17 on hooks/hooks script.
Besides, hooks/common.py was changed as relation-get returns bytearray
format instead of string format, which does not work on py3.

67. By Simon Poirier on 2018-11-08

Handle py2 and py3 by opening a file in wb mode.

66. By Simon Poirier on 2018-02-27

Merge 1750668_bionic_py3_support [f=1750668] [r=chad.smith,landscape-builder] [a=Simon Poirier]
Wrap hooks hooks to run on version used by landscape-client and correct a couple imports which changed.

65. By Xav Paice on 2018-02-22

Merge landscape-client-charm [f=1723363] [r=simpoir,landscape-builder] [a=Xav Paice]
add optional override for unattended-upgrades

64. By Björn Tillenius on 2017-03-14

Merge update-source [f=1668166] [r=landscape-builder,free.ekanayaka,ack] [a=Björn Tillenius]
Add the new origin/source and upgrade landscape-client if the origin is
changed after the deploy.

Before origin was read only during the install hook, and we ignored any
changes to it after that.

63. By Chad Smith on 2017-03-03

Merge add-apt-repository-retries [f=] [r=landscape-builder,ericsnowcurrently] [a=Chad Smith]
Sync charmhelpers for add_source retries to avoid hook errors on network timeouts. Because of charmhelpers sync fetch._run_apt_command moved to fetch.ubuntu._run_apt_command and fetch has new dependency on osplatform

62. By Alberto Donato on 2017-01-09

Merge multi-series [f=] [r=ericsnowcurrently,danilo,landscape-builder] [a=Alberto Donato]
Make the charm multi-series (for trusty and xenial).
This also drops references (and backward compatible logic) for precise, since we don't support it anymore.

61. By Andreas Hasenack on 2016-07-28

Merge ci-test-makefile-target [f=1607043] [r=ack,simpoir] [a=Andreas Hasenack]
Add a ci-test makefile target that will run the tests and install any needed dependencies before.

60. By Adam Collard on 2016-05-26

Merge juju_2_support [f=1572575] [r=bogdana,ack] [a=Adam Collard]

Add support for Juju 2.0's changed environment variable name.

59. By Chris Glass on 2016-05-02

Make install hook to run on python3 since python (2) is not installed on xenial+ by default. [trivial] [r=free]

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:landscape-client-charm
This branch contains Public information 
Everyone can see this information.

Subscribers