lp:~peter-pearse/ubuntu/natty/libxml2/prop001

Created by Peter Pearse on 2011-04-08 and last modified on 2011-04-08
Get this branch:
bzr branch lp:~peter-pearse/ubuntu/natty/libxml2/prop001
Only Peter Pearse can upload to this branch. If you are Peter Pearse please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Peter Pearse
Status:
Development

Recent revisions

41. By Peter Pearse on 2011-04-08

Patch for cross building.

40. By Mike Hommey <email address hidden> on 2010-12-25

xpath.c: Fix a double-freeing error in XPath processing code.
(CVE-2010-4494). Closes: #607922.

39. By Mike Hommey <email address hidden> on 2010-11-05

* New upstream release.
* configure.in: Applied upstream fix to reactivate symbol versioning script.

38. By Mike Hommey <email address hidden> on 2010-06-29

* debian/rules:
  - Use a variable to express which sub-targets to invoke for
    configure/build/install.
  - Refactor configure-% and build-% rules.
  - Avoid possible renaming of _d.so files to _d_d.so files in the
    install-python%-dbg rules.
* debian/control, debian/control.udeb, debian/libxml2-udeb.install,
  debian/rules: Add an udeb package when building for Ubuntu.
  Closes: #583767.
* debian/control:
  - Remove old Conflicts/Replaces for packages that have disappeared before
    etch.
  - Bump Standards-Version to 3.9.0.0.

37. By Loïc Minier on 2010-05-30

* Shuffle old Debian changelog entries around to match the Debian layout and
  reduce the diff.
* Drop /usr/share/doc/python-libxml2-dbg -> python-libxml2 symlink which was
  added to optimize disk space, the -dbg package is huge anyway. Add a
  preinst snippet to deal with upgrades.
* Merge with Debian.
  - Keep the new Debian build-deps "libreadline-dev | libreadline5-dev"
    since this should work fine with Ubuntu buildds reinstalling everything
    on each build.
  - Drop duplicate -Wall and -g from -dbg CFLAGS.
  - Drop addition of -Wl,-Bsymbolic-functions to LDFLAGS since LDFLAGS
    aren't overriden in the Debian rules anymore.
  - Don't set PYTHON_VERSION and PYTHON_SITE_PACKAGES during python$*-dbg
    builds since these should be correct already.
  - Drop explicit zlib1g-dev dep, .pc only mentions zlib in Libs.private and
    the .la file isn't shipped anymore, so there should be no mention of -lz
    requiring this anymore.
  - Rework creation of -dbg package (python$*-dbg) for the new dh 7 rules;
    install to debian/tmp-dbg.
  - Remaining changes:
    + Add python-libxml2-dbg package built with python$*-dbg and these
      CFLAGS: -Wall -Wextra -g -O0 -fno-strict-aliasing -pedantic.
    + Add libxml2-udeb package.
    + Fix debian/python-libxml2.install to cope with builds which don't have
      any site-packages based python versions.
    + rm -rf build-python$* in configure-python% to fix FTBFS.
* Fix dependency of python-libxml2-dbg on python-libxml2 to use
  ${binary:Version}, not ${source:Version}.
* Add ${misc:Depends} to python-libxml2-dbg.

36. By Scott Kitterman on 2009-12-15

* Merge from debian testing, remaining changes:
  - Create -udeb and python -dbg packages
  - Link using -Bsymbolic-functions
  - Add missing zlib1g-dev to -dev
  - Fix site-/dist-packages
  - Build-depend on libreadline6-dev instead of libreadline5-dev.

35. By Matthias Klose on 2009-10-08

* Merge with Debian (LP: #433253); remaining changes:
  - Create -udeb and python -dbg packages
  - Link using -Bsymbolic-functions
  - Add missing zlib1g-dev to -dev
  - Fix site-/dist-packages
  - error.c: Grab fix from SVN to avoid pidgin/jabber crash
  - Build-depend on libreadline-dev instead of libreadline5-dev.

34. By Matthias Klose on 2009-09-19

Build-depend on libreadline-dev instead of libreadline5-dev.

33. By Michael Terry on 2009-06-12

* Merge from debian unstable (LP: #386390), remaining changes:
  - Create -udeb and python -dbg packages
  - Link using -Bsymbolic-functions
  - Add missing zlib1g-dev to -dev
  - Fix site-/dist-packages
  - error.c: Grab fix from SVN to avoid pidgin/jabber crash

32. By Sebastien Bacher on 2009-04-08

error.c: use svn change to fix error handling issues leading to pidgin crash
when connecting jabber (lp: #357949)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/natty/libxml2
This branch contains Public information 
Everyone can see this information.

Subscribers