Merge lp:~persia/unity-gtk-module/blacklist-freeciv-harder into lp:unity-gtk-module

Proposed by Emmet Hikory on 2016-03-11
Status: Needs review
Proposed branch: lp:~persia/unity-gtk-module/blacklist-freeciv-harder
Merge into: lp:unity-gtk-module
Diff against target: 11 lines (+1/-0)
1 file modified
src/main.c (+1/-0)
To merge this branch: bzr merge lp:~persia/unity-gtk-module/blacklist-freeciv-harder
Reviewer Review Type Date Requested Status
Indicator Applet Developers 2016-03-11 Pending
Review via email: mp+288835@code.launchpad.net

Description of the change

The freeciv project is now recommending freeciv-gtk3 as the preferred client for freeciv, which needs the same blacklist hack to support the city dialog, diplomacy dialog, and other windows. freeciv-gtk2 is still supported, so both need to be blacklisted for the time being.

To post a comment you must log in.
William Hua (attente) wrote :

Hello, lgtm, but what package is providing freeciv-gtk3? Can't seem to find it in any of the freeciv packages.

Emmet Hikory (persia) wrote :

Update: on advice, I filed Bug #1556277 to specifically address the gtk3 case.

Emmet Hikory (persia) wrote :

Should be "freeciv-client-gtk", but I'll go investigate to make sure that's true, and if it isn't, fix it.

Unmerged revisions

336. By Emmet Hikory on 2016-03-11

Add freeciv-gtk3 to blacklist (Fixes: #1242937)

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'src/main.c'
2--- src/main.c 2014-06-09 03:50:16 +0000
3+++ src/main.c 2016-03-11 20:33:00 +0000
4@@ -35,6 +35,7 @@
5 "emacs24-lucid",
6 "freeciv",
7 "freeciv-gtk2",
8+ "freeciv-gtk3",
9 "glade",
10 "gwyddion",
11 NULL

Subscribers

People subscribed via source and target branches