Merge ~paelzer/ubuntu/+source/php7.3:bug-1850933-mod-php-ordering-on-install into ~usd-import-team/ubuntu/+source/php7.3:ubuntu/eoan-devel

Proposed by Christian Ehrhardt  on 2019-11-11
Status: Work in progress
Proposed branch: ~paelzer/ubuntu/+source/php7.3:bug-1850933-mod-php-ordering-on-install
Merge into: ~usd-import-team/ubuntu/+source/php7.3:ubuntu/eoan-devel
Diff against target: 39 lines (+9/-0)
3 files modified
debian/changelog (+7/-0)
debian/control (+1/-0)
debian/control.in (+1/-0)
Reviewer Review Type Date Requested Status
Canonical Server Team 2019-11-11 Pending
Canonical Server packageset reviewers 2019-11-11 Pending
Ubuntu Server Dev import team 2019-11-11 Pending
Review via email: mp+375381@code.launchpad.net
To post a comment you must log in.
Christian Ehrhardt  (paelzer) wrote :

This isn't yet intended for an upload, it just accompanies the bug 1850933 to discuss the changes.

Unmerged commits

f9d3a61... by Christian Ehrhardt  on 2019-11-11

changelog: conflict mod-php with former php versions for better upgrade ordering (LP: #1850933)

Signed-off-by: Christian Ehrhardt <email address hidden>

325803d... by Christian Ehrhardt  on 2019-11-11

d/control: conflict mod-php with former php versions for better upgrade ordering (LP: #1850933)

Signed-off-by: Christian Ehrhardt <email address hidden>

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
diff --git a/debian/changelog b/debian/changelog
index 34701e3..f4a4026 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
1php7.3 (7.3.11-0ubuntu0.19.10.2) eoan; urgency=medium
2
3 * d/control, d/control.in: conflict mod-php with former php versions
4 for better upgrade ordering (LP: #1850933)
5
6 -- Christian Ehrhardt <christian.ehrhardt@canonical.com> Mon, 11 Nov 2019 10:57:12 +0100
7
1php7.3 (7.3.11-0ubuntu0.19.10.1) eoan-security; urgency=medium8php7.3 (7.3.11-0ubuntu0.19.10.1) eoan-security; urgency=medium
29
3 * SECURITY UPDATE: updated to 7.3.11 to fix security issue10 * SECURITY UPDATE: updated to 7.3.11 to fix security issue
diff --git a/debian/control b/debian/control
index 16184c9..6f6afe6 100644
--- a/debian/control
+++ b/debian/control
@@ -96,6 +96,7 @@ Depends: libmagic1,
96 ${shlibs:Depends}96 ${shlibs:Depends}
97Provides: libapache2-mod-php,97Provides: libapache2-mod-php,
98 ${php:Provides}98 ${php:Provides}
99Conflicts: libapache2-mod-php7.2
99Recommends: apache2100Recommends: apache2
100Suggests: php-pear101Suggests: php-pear
101Description: server-side, HTML-embedded scripting language (Apache 2 module)102Description: server-side, HTML-embedded scripting language (Apache 2 module)
diff --git a/debian/control.in b/debian/control.in
index 169da0b..6bf5f45 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -97,6 +97,7 @@ Depends: libmagic1,
97Provides: libapache2-mod-php,97Provides: libapache2-mod-php,
98 ${php:Provides}98 ${php:Provides}
99Recommends: apache299Recommends: apache2
100Conflicts: libapache2-mod-php7.2
100Suggests: php-pear101Suggests: php-pear
101Description: server-side, HTML-embedded scripting language (Apache 2 module)102Description: server-side, HTML-embedded scripting language (Apache 2 module)
102 This package provides the PHP module for the Apache 2 webserver (as103 This package provides the PHP module for the Apache 2 webserver (as

Subscribers

People subscribed via source and target branches